Bug 139434 - I18N - Filter wizard doesn't resize to show its text
I18N - Filter wizard doesn't resize to show its text
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Trey Spiva
issues@javaee
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-09 17:33 UTC by kaa
Modified: 2010-01-12 02:12 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
image (101.50 KB, image/jpeg)
2008-07-09 17:34 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2008-07-09 17:33:50 UTC
Product Version: NetBeans IDE Dev (Build 200806220002)
Java: 1.6.0_06; Java HotSpot(TM) Client VM 10.0-b22
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
I'm running in the Japan locale, using a pseudo localized Netbeans with font size 16 option.

1. Create WebApp
2. Open NewFile  -> Web -> Filter wizard
3. Go to the step 3 (Configure Filter Deployment)

The wizard doesn't resize to show its text. See image.

Assumption is that user does not need to manually resize most windows or dialogs to see all of the UI objects and
information in them. I'm running in pseudo localized locale in which each message/label is sometimes longer than in
English. To account for that in some locales, translations from English (and some other euro languages) could be shown
with longer strings.

Also I'm running at font size 16, which is viewed as a valid font size that might be used. Resizing issues are not just
related to i18n; they might show to user in English locale if they run at larger font size.

Often, these issues happen because the length of some label or message or size of entire window is hardcoded vs using
layout managers or other techniques or api to have the windows or the objects in them, dynamically resize.
Comment 1 kaa 2008-07-09 17:34:19 UTC
Created attachment 64195 [details]
image
Comment 2 kaa 2008-07-09 17:35:59 UTC
the same with 0629 build
Comment 3 Samaresh Panda 2008-07-28 23:47:47 UTC
Looking into it...
Comment 4 Samaresh Panda 2008-07-29 16:04:24 UTC
Can someone explain me how can I see this wizard? Do I have to install some other plugin? Where is the Filter Wizard?
Comment 5 Petr Jiricka 2008-07-29 16:51:38 UTC
In a web project, choose New file, and in "Web" category Filter is the 3rd on the list.
Comment 6 Samaresh Panda 2008-07-29 22:28:12 UTC
I spent some time on it, but it is not as simple as it sounds. I got into web.core's wizard package where the
Bundle.properties defines name/value pairs for messages that are displayed in the panel

TITLE_ddpanel_filter=Configure Filter Deployment
LBL_dd_filter=<html>Register the Filter ....</html> 

However, I can't find the panel where these are used. Any ideas??
Comment 7 pslechta 2008-09-10 11:59:12 UTC
See class org.netbeans.modules.web.wizards.DeployDataPanel in web.core module.

However, it won't be easy to fix it properly.
(1) The panel is not editable in visual editor (no .form file)
(2) It is not easy to limit width of JLabel in GraidBagLayout (see
http://forums.sun.com/thread.jspa?threadID=5135017&messageID=9494204 for details)

Easy, but not nice fix, would be to increase preferred size of the panel...
Comment 8 Petr Jiricka 2008-09-16 15:02:04 UTC
> Easy, but not nice fix, would be to increase preferred size of the panel...

Sounds possible, but this would have some disadvantages besides the advantages. 

This does not sounds like a P2, because:
- the wizard can be used and successfully completed even without seeing this complete text; it is not required for
understanding the functionality of the wizard
- manually resizing is an obvious and easy workaround

I suggest changing priority to P3, what do you think?
Comment 9 Ken Frank 2008-09-16 15:50:12 UTC
this one  is different than most if not all resize
kind of issues in that the problem is with the vertical view of characters,
and actually affects english also; we have seen this sometimes with jtable or
jtree but not before with other objects.

in other multibyte languages, the context of what a character is if some vertical
part of it is missing can be confusing even more than case for ascii.

since its late in cycle, I'd suggest waiving it and fixing for next release.

resizing is not a workaround for these kind of issues as per nb policy 
(not talking about bug criteria) though of course user can do it,
although sometimes that does not even work if hardcoding has happened
but the fact that some window can be made to shown all by resizing is
not a real workaround officially.

the other issues seen vertically were fixed by either not hardcoding,
using window manager for handling resizing or for jtable/jtree getting
the overall size of the text and adding a margin vs hardcoding.

ken.frank@sun.com
Comment 10 Petr Jiricka 2008-09-17 15:48:23 UTC
Requesting a waiver for NetBeans 6.5. 

User impact: slightly decreased usability of the New Filter wizard, which is one of the less prominent Web tier
components, for users running in non-English locales.

Workarounds: 1. use the feature anyway, even if the explanatory text (which is not essential for understanding the
feature) is not completely readable, or: 2. create the component as an ordinary class and then declare it in the
deployment descriptor using the web.xml editor (textual or visual).

Justification: the proper fix that would not cause other regressions is non-trivial, and given the number of other tasks
required to meet the quality criteria, there is no time to fix this for 6.5.
Comment 11 Petr Jiricka 2008-09-19 21:35:34 UTC
The waiver is approved.
Comment 12 Trey Spiva 2008-11-07 18:02:51 UTC
>> Easy, but not nice fix, would be to increase preferred size of the panel...
>
> Sounds possible, but this would have some disadvantages besides the advantages. 

What are the disadvantages of increasing the size of the panel?  Is because the wizard dialog changes size?  Obviously the preferred size will have to be 
dynamically determined to make sure that the text fits no matter what the font size.
Comment 13 Trey Spiva 2008-11-10 18:00:06 UTC
>> - the wizard can be used and successfully completed even without seeing this complete text; it is not required for
>>    understanding the functionality of the wizard

If the wizard can be successfully completed event without seeing the text, is the text required.  Maybe the wizard should not include the instructions.
Comment 14 Trey Spiva 2008-11-18 22:52:36 UTC
moving his issue to later
Comment 15 Quality Engineering 2009-11-02 11:17:43 UTC
NetBeans.org Migration: changing resolution from LATER to WONTFIX


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo