Bug 139305 - ability to define name and add metadata to snapshots
ability to define name and add metadata to snapshots
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P3 with 1 vote (vote)
: 7.2
Assigned To: Jiri Sedlacek
issues@profiler
: VISUALVM
: 69207 70211 71047 187018 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-08 19:27 UTC by jamesvera
Modified: 2012-09-27 15:07 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jamesvera 2008-07-08 19:27:39 UTC
After creating a snapshot it would be nice to associate some metadata with it.  That could be used to record things like
the conditions under which the snapshot was created.  Maybe one distinguished metatdata field, like "name" and another
free form field.  The name could be used as the tool tip for the snapshot's tab.
Comment 1 Jiri Sedlacek 2010-09-06 14:30:32 UTC
*** Bug 187018 has been marked as a duplicate of this bug. ***
Comment 2 Jiri Sedlacek 2010-09-06 14:30:46 UTC
*** Bug 69207 has been marked as a duplicate of this bug. ***
Comment 3 Jiri Sedlacek 2010-09-06 14:31:01 UTC
*** Bug 71047 has been marked as a duplicate of this bug. ***
Comment 4 Jiri Sedlacek 2010-09-06 14:32:27 UTC
*** Bug 70211 has been marked as a duplicate of this bug. ***
Comment 5 neilwightman 2011-04-28 06:55:53 UTC
JVisualVM allows this so I dont know why netbeans cant do it.
Comment 6 Jiri Sedlacek 2011-11-22 16:26:19 UTC
Implemented by http://hg.netbeans.org/profiler-main/rev/79162b614560.
Comment 7 Quality Engineering 2011-11-27 17:00:23 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/79162b614560
User: Jiri Sedlacek <jis@netbeans.org>
Log: Implemented #139305 - rename snapshot & user comments


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo