Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 138988 - External SU DnD onto CASA does not create an EP with right information
External SU DnD onto CASA does not create an EP with right information
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: Composite Application
6.x
All All
: P1 (vote)
: TBD
Assigned To: Jun Qian
issues@soa
61fixes3-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-04 03:46 UTC by Murali Pottlapelli
Modified: 2008-09-04 13:24 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
SA to reproduce the issue (5.44 KB, application/octet-stream)
2008-07-04 03:47 UTC, Murali Pottlapelli
Details
an SA for testing purpose (9.29 KB, application/x-compressed)
2008-07-08 01:12 UTC, Jun Qian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Murali Pottlapelli 2008-07-04 03:46:00 UTC
External SU DnD onto CASA does not create an EP with right information. NS is invalid.

ALEServiceAssembly-sun-ale-engine with following descriptor is dropped on to CASA canvas

Jun and I did following two steps to fix the issue
1. Rename ale to ns0
2. moved NS declaration to jbi element.

<?xml version="1.0" encoding="UTF-8"?>
<jbi xmlns="http://java.sun.com/xml/ns/jbi" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" version="1.0"
xsi:schemaLocation="http://java.sun.com/xml/ns/jbi jbi.xsd">
    <services binding-component="false" 
              xmlns:ale="http://www.sun.com/ALE/1.0/ALEService.wsdl" >
        <provides endpoint-name="ALELoggingEndpoint" interface-name="ale:ALEServiceLoggingPortType" 
                  service-name="ale:LoggingService"/>
        <provides endpoint-name="ALEAlertEndpoint" interface-name="ale:ALEServiceAlertPortType" 
                  service-name="ale:AlertService"/>
        <provides endpoint-name="ALEErrorEndpoint" interface-name="ale:ALEServiceErrorPortType" 
                  service-name="ale:ErrorService"/>
    </services>
</jbi>
Comment 1 Murali Pottlapelli 2008-07-04 03:47:14 UTC
Created attachment 63916 [details]
SA to reproduce the issue
Comment 2 Jun Qian 2008-07-08 00:53:39 UTC
Fixed in soa-dev branch. Changeset: d8742363cfc2
Comment 3 Jun Qian 2008-07-08 01:10:10 UTC
This namespace related issue doesn't show up with BPEL/XSLT projects types. However, it could surface when new SU
project types are integrated into compapp, as shown in Murali's case. Jen, I would highly recommend we include this fix
in 6.1 Patch 3.

To verfiy the fix without installing a new SE plugin into your NetBeans, 

1. Deploy the attached service assembly (a SynchronousSampleApplication with a slightly-modified-but-still-valid BPEL SU
jbi.xml)
2. Create a new CompApp project, open CASA Editor
3. Drag the BPEL SU from the deployed SA in JBI Manager (SynchronousSample13Application-SynchronousSample13) and drop it
into CASA
4. Select the Provide endpoint in CASA and check its interface

The interface reads:
=> (INCORRECT)  {http://java.sun.com/xml/ns/casa}portType1
=> (CORRECT)    {http://localhost/SynchronousSample/SynchronousSample}portType1



Comment 4 Jun Qian 2008-07-08 01:12:52 UTC
Created attachment 64041 [details]
an SA for testing purpose
Comment 5 jlautz 2008-08-04 17:37:39 UTC
Verified fixed with soa-dev sierra build sierra_2682_20080801_1723_dev.zip -- jun's scenario works as expected

However, in 6.5 trunk build netbeans-trunk-nightly-200808021401-solaris-x86.sh, when I do the same scenario, I get the
"incorrect" interface for the BPEL SU external module provides interface: http://java.sun.com/xml/ns/casa}portType1

Comment 6 rbalada 2008-08-04 20:55:56 UTC
For inclusion in NB 6.1 Patch 3, please provide fully qualified URL to changeset (not just changeset ID to some
proprietary repository). Ideally trunk changeset URL. 
Comment 7 rbalada 2008-08-04 21:35:26 UTC
Jennifer,

it looks like you REOPENED this issue with a comment, that it's VERIFIED. Please update this issue into consistent state.
Don't forget to specify fully qualified URL to changeset.

Thanks,
-R
Comment 8 Jun Qian 2008-08-04 21:50:38 UTC
The fully qualified changeset URL (in soa-dev branch) is http://hg.netbeans.org/soa-dev/rev/d8742363cfc2

I think I didn't integrate the fix in the trunk. I will do that shortly.
Comment 9 Jun Qian 2008-08-04 23:36:33 UTC
Changeset d8742363cfc2 in soa-dev has been transplanted as 0555ba0727fa (http://hg.netbeans.org/main/rev/0555ba0727fa)
into trunk.

Comment 10 Jun Qian 2008-08-04 23:36:57 UTC
Fixed in trunk.
Comment 11 jlautz 2008-08-05 15:22:57 UTC
Verified fixed in 6.5 trunk with build netbeans-trunk-nightly-200808050201.
Comment 12 rbalada 2008-08-05 21:19:50 UTC
I've transplanted the changeset http://hg.netbeans.org/main/rev/0555ba0727fa into release61_fixes repository as
http://hg.netbeans.org/release61_fixes/rev/36ad9ecb9746


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo