Bug 138764 - I18N - word DefaultConfiguration on toolbar config dropdown not from bundle
I18N - word DefaultConfiguration on toolbar config dropdown not from bundle
Status: RESOLVED INVALID
Product: javame
Classification: Unclassified
Component: -- Other --
6.x
Sun All
: P2 (vote)
: TBD
Assigned To: Petr Suchomel
issues@mobility
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-01 23:33 UTC by Ken Frank
Modified: 2008-07-31 21:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2008-07-01 23:33:21 UTC
when mobility project is main project, the toolbar has a configuration dropdown
that lets one choose the configuration  or choose to customize it the word 
DefaultConfiguration is not from bundle file

for java project, the words are from bundle file - they are called
"default configuration"

could the words in mobilty for this be 2 separate words like Default Configuration
so could be clearer for translation ?
Comment 1 Lukas Hasik 2008-07-02 08:16:23 UTC
it seems that the issue is a duplicate of an existing issue...

1, the DefaultConfiguration is used in preprocessor. Preprocessor variable is required to be java compliant. 
2, IMHO, it has no sense to translate DefaultConfiguration at all -> closing as invalid.

Reassigning to Petr to comment
Comment 2 Lukas Hasik 2008-07-02 08:17:36 UTC
closing
Comment 3 Ken Frank 2008-07-31 21:45:22 UTC

is the word DefaultConfiguration a reserved word itself ?
I see in java project its called default-config,
which would not be translated also 

however translated word (or users own name of a configuration)
can have multibyte in it since that is java compliant, and I created
one for a mobility project with such a name and it built and ran ok.

but if this wording has been this way for previous release, it seems
ok to leave it closed.

I realized that perhaps rfe in general might be to have a display name
on the toolbar to tell what this dropdown is - I don't see one
but thats not for mobility per se.
Comment 4 Ken Frank 2008-07-31 21:47:05 UTC
last part of last comment can be ignored as there is tooltip that
describes what the dropdown is.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo