Bug 138462 - Breakpoints view > Enable all causes exception + task freeze on JRuby
Breakpoints view > Enable all causes exception + task freeze on JRuby
Status: RESOLVED DUPLICATE of bug 148583
Product: ruby
Classification: Unclassified
Component: Debugger
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Martin Krauskopf
issues@ruby
http://wiki.netbeans.org/TS_61_RubyDe...
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-27 11:02 UTC by polan
Modified: 2008-10-10 15:57 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
RubyDebuggerException (2.77 KB, text/plain)
2008-06-27 11:03 UTC, polan
Details
Thread dump (23.91 KB, text/plain)
2008-06-27 11:04 UTC, polan
Details
Error dialog (16.67 KB, image/png)
2008-06-27 11:04 UTC, polan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description polan 2008-06-27 11:02:38 UTC
[NetBeans 6.5M1, Build 200806270102, JDK 1.6.0]

This was found when testing http://wiki.netbeans.org/TS_61_RubyDebugger Ruby Debugger - Section 9, Task 10.

To reproduce:
1) Have a Ruby project on Built-in JRuby platform with main.rb file like:

  def fib(n)
    if n<2 then #BREAKPOINT HERE 
      return n
    else
      return fib(n-1) + fib(n-2)
    end
  end

  5.times do |i|
    puts fib(i) #BREAKPOINT HERE
  end

2) Call debug, in Breakpoints view call context menu > Disable all

3) Call context menu > Enable all
ERROR: IDE freezes for 15 seconds

ERROR: Dialog appears 'Problem occured during debugger start: Unable to read added breakpoint number in the specified 
timeout [15s]' (image attached)
ERROR: org.rubyforge.debugcommons.RubyDebuggerException occurs (Exception and thread dump attached)

ERROR: Debugging functions are now out of order (Continue, Step...).
NOTE: Disable all and Enable all works fine now :)

ERROR: This also causes the debug task to become unkillable exactly the same way as described in Issue 138449. Have to 
kill it manually in OS.

NOTE: This does not happen with Ruby 1.8.6-p111 platform
Comment 1 polan 2008-06-27 11:03:17 UTC
Created attachment 63587 [details]
RubyDebuggerException
Comment 2 polan 2008-06-27 11:04:03 UTC
Created attachment 63588 [details]
Thread dump
Comment 3 polan 2008-06-27 11:04:40 UTC
Created attachment 63589 [details]
Error dialog
Comment 4 Martin Krauskopf 2008-07-04 14:50:33 UTC
I'm not able to reproduce. It is random or does it happen always. If always could you provide detailed logs as described at:

  http://wiki.netbeans.org/RubyDebugging#section-RubyDebugging-HowToFileABug

Thanks.
Comment 5 Martin Krauskopf 2008-07-18 11:26:15 UTC
I can't reproduce. Lowering priority, seems to be rare random issue. Please attach the logs as described if you are able
to reproduce, thanks.
Comment 6 Martin Krauskopf 2008-10-10 15:57:15 UTC
Was fixed as part of issue #148583. Duping this one.

*** This issue has been marked as a duplicate of 148583 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo