Bug 138348 - Quoted table isn't visible
Quoted table isn't visible
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
All Windows XP
: P1 (vote)
: 6.x
Assigned To: Andrei Badea
issues@db
fix-in-65
:
Depends on:
Blocks: 139373
  Show dependency treegraph
 
Reported: 2008-06-26 12:33 UTC by Roman Mostyka
Modified: 2008-07-23 17:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Mostyka 2008-06-26 12:33:50 UTC
1. Connect to MySQL DB.
2. Open SQL Editor.
3. Execute following statement: "create table `quo+ted` (`i-d` int primary key );". Message that statement is executed
successfully appears.
4. Rightclick "Tables" node and choose "Refresh".

Result: There is no table `quo+ted` under "Tables" node.
Comment 1 Roman Mostyka 2008-07-15 11:46:56 UTC
Set priority to P1, since workaround is to use not quoted table doesn't fit customers who use existing DB.
This issue also blocks verifying of the issue #139373.
Comment 2 Andrei Badea 2008-07-18 13:41:02 UTC
Not reproducible for me in the 080717 build on Linux. After invoking Refresh once, the table is displayed. After
invoking it for the second time, an exception is thrown, but that's a separate issue (I think filed already?).

Roman, can you always reproduce? If so, please send driver version and details to connect to the server. Also, is there
anything interesting in the message log?

Downgrading since it looks like a random issue.
Comment 3 Roman Mostyka 2008-07-18 16:26:25 UTC
I reproduced it on Windows XP all the time. So it's P1 for me. And I don't have any exception in the log file.
Here is my product data:
Product Version: NetBeans IDE Dev (Build 080718)
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b13
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)
Draw attention that I use Russian locale. Can it be the reason?
Anyway, if needed we can setup VNC session on Monday.
Comment 4 John Baker 2008-07-21 23:34:14 UTC
Andrey do you also see this quote problem ?
Comment 5 John Baker 2008-07-21 23:45:10 UTC
I cannot reproduce on Mac - the quoted table appears after refreshing the connection node.

Roman, did you refresh the connection node after executing the command?

If the table still doesn't appear after refreshing then perhaps this only occurs in another locale.
Comment 6 kaa 2008-07-22 13:48:21 UTC
I saw the same problem with mbyte in name of the table.
See issue 128729. Also I was able to reproduce this issue in Ja locale.

Product Version: NetBeans IDE Dev (Build 20080721233246)
Java: 1.6.0_06; Java HotSpot(TM) Client VM 10.0-b22
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
Comment 7 Roman Mostyka 2008-07-22 15:59:04 UTC
After some investigation Andrei found that MySQL driver doesn't return tables with mbyte characters in the name.
So this issue isn't valid anymore and I close it.
Filed also issue against installer for MySQL: #141188.
Comment 8 Roman Mostyka 2008-07-22 15:59:47 UTC
Verified with build 080722.
Comment 9 Ken Frank 2008-07-22 16:17:34 UTC
just checking - is resolution that the problem still happens
but its mysql issue ?

perhaps can be marked with relnote keyword ?
(since seen in other issues by those in asian locales)

ken.frank@sun.com
Comment 10 Ken Frank 2008-07-22 20:17:43 UTC
what are the details about mysql driver not returning tables with mbyte
in name - is this filed as mysql issue or driver issue ?

we need this info for release notes or other faq

does it mean that regardless of encoding user cannot use non ascii
in name of table or col name of mysql dbase ?

and how can this issue be closed as verified and fixed if there was no
fix to it ?

ken.frank@sun.com

ken.frank@sun.com
Comment 11 Roman Mostyka 2008-07-23 09:31:14 UTC
Ken, I installed mysql on my localhost, but I worked in Russian locale and I tried to create `quo+ted` table, but I
didn't see it under "Tables" node.
Then Andrei Badea suggest to check if mysql driver return this table. With simple code we checked that it doesn't and
therefore such tables aren't visible in DB Explorer. So the problem is that driver "don't see" such tables and this is
not NetBEans problem, but rather MySQL and installer.
Then I installed latest stable mysql build and set for it utf8 enconding (not latin1, which is default) and with this
installation everything works fine for me. I'm able now to create tables with non-ascii symbols in a name.
So therefore this issue doesn't exist for me anymore, because it was fixed by setup of mysql and I closed this issue and
open new one for installer, since customer should be able to install what is necessary and then just work and arised
problem is issue of mysql setup.
Comment 12 John Baker 2008-07-23 09:40:49 UTC
what is the issue number for the new installer issue?
Comment 13 Roman Mostyka 2008-07-23 09:49:06 UTC
As I wrote it is issue #141188.
Comment 14 Ken Frank 2008-07-23 17:18:05 UTC
Roman,
just to clarify, by installer setting the server encoding for the dbase, it does
solve the problem you saw here, or by you setting the encoding yourself for standalone ?

if so, what is the setting command you used ? I'd like to collect info for faq for users
about this; I realize there are various places in mysql where character set/encoding
can be set as to server, dbase, table views of charset/encodings.

ken.frank@sun.com
Comment 15 Roman Mostyka 2008-07-23 17:31:38 UTC
I set utf8 enconding during installation process of MySQL. MySQL installer suggests such option. And after this issue
has gone.
But Andrey said me that he installed MySQL with default settings (he didn't change anything) in Japan locale and
everything is fine for him also. So in this case there is 2 possibility:
1) MySQL installer can set utf8 by itself if it recognizes locale with non-ascii symbols (probably Andrey's case) or it
can be done manually with installer for any locale (my case).
2) MySQL installer just setup MySQL somehow and everything works fine then (without changing of encoding).
I wrote about point 2) because Andrey didn't change anything, but everything works fine for him, so or installer set
utf8 by itself or the problem not in encoding, but in some other settings.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo