Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 138326 - IllegalStateException: Method must be invoked from EDT
IllegalStateException: Method must be invoked from EDT
Status: VERIFIED FIXED
Product: groovy
Classification: Unclassified
Component: Grails
6.x
All Linux
: P3 (vote)
: 6.x
Assigned To: Petr Hejl
issues@groovy
http://statistics.netbeans.org/except...
:
Depends on: 135670
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-26 10:31 UTC by Lukas Jungmann
Modified: 2008-10-30 14:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jungmann 2008-06-26 10:31:58 UTC
Build: NetBeans IDE Dev (Build 20080624154200)
VM: Java HotSpot(TM) Client VM, 10.0-b22, Java(TM) SE Runtime Environment, 1.6.0_06-b02
OS: Windows XP, 5.1, x86
User comments: Trying to creat a new grails project. Error occures every time when clicking on finish.
STACKTRACE: (first 10 lines)
java.lang.IllegalStateException: Method must be invoked from EDT
        at org.netbeans.modules.extexecution.api.ExecutionService.run(ExecutionService.java:176)
        at org.netbeans.modules.extexecution.api.ExecutionService.run(ExecutionService.java:171)
        at
org.netbeans.modules.groovy.grailsproject.ui.wizards.NewGrailsProjectWizardIterator.instantiate(NewGrailsProjectWizardIterator.java:115)
        at org.openide.loaders.TemplateWizard$InstantiatingIteratorBridge.instantiate(TemplateWizard.java:1023)
        at org.openide.loaders.TemplateWizard.handleInstantiate(TemplateWizard.java:595)
        at org.openide.loaders.TemplateWizard.instantiateNewObjects(TemplateWizard.java:416)
        at org.openide.loaders.TemplateWizardIterImpl.instantiate(TemplateWizardIterImpl.java:253)
        at org.openide.loaders.TemplateWizardIteratorWrapper.instantiate(TemplateWizardIteratorWrapper.java:165)
        at org.openide.WizardDescriptor.callInstantiateOpen(WizardDescriptor.java:1384)
        at org.openide.WizardDescriptor.callInstantiate(WizardDescriptor.java:1341)
Comment 1 Lukas Jungmann 2008-06-26 10:45:07 UTC
seems to be reproducible only in trunk; works fine in 6.5M1 build...
Comment 2 Exceptions Reporter 2008-06-26 18:48:21 UTC
This issue has already 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=69441
Comment 3 martin_adamek 2008-06-26 19:05:25 UTC
As there are duplicates coming and people asking about this problem, i have just small advice/workaround: create Grails application in command line ('grails 
create-app someName') and then open it in NetBeans as any other NetBeans project (File -> Open Project). You don't need to do any import, NetBeans 
understands any existing Grails application.
Comment 4 Petr Hejl 2008-06-26 21:22:05 UTC
Workarounded in trunk ab27dd83f970. Lowering priority - leaving as reminder.
Comment 5 Petr Hejl 2008-07-07 21:31:40 UTC
Fixed by the change in extexecution.
Comment 6 Lukas Jungmann 2008-08-07 16:44:33 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo