Bug 138316 - Bundle jdbcmysql and jdbcpostgresql adapters
Bundle jdbcmysql and jdbcpostgresql adapters
Status: RESOLVED FIXED
Product: ruby
Classification: Unclassified
Component: Rails
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Erno Mononen
issues@ruby
:
: 138527 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-26 09:24 UTC by Erno Mononen
Modified: 2009-02-19 23:01 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erno Mononen 2008-06-26 09:24:21 UTC
The jdbcmysql and jdbcpostgresql adapters allows to use more Rails like configuration in database.yml, which in turn 
should make the create:db task work with JDBC connections as well.
Comment 1 Erno Mononen 2008-06-30 14:36:31 UTC
After giving this a second thought, I'm downgrading this to P3 on the basis that for MySQL we already have create db 
functionality that works with JDBC too. Targetting 6.5 nevertheless.
Comment 2 Chris Kutler 2008-08-13 16:44:40 UTC
This change affects the documentation (setting-up.html), the book, as well as this FAQ:
http://wiki.netbeans.org/FaqRailsJRubyDatabaseAccess. Making a note of this here so I will remember to make these
changes when this gets fixed.
Comment 3 Erno Mononen 2008-08-18 11:51:36 UTC
*** Issue 138527 has been marked as a duplicate of this issue. ***
Comment 4 Erno Mononen 2008-08-18 11:52:26 UTC
See also issue 138527 and http://jira.codehaus.org/browse/JRUBY-2715.
Comment 5 Erno Mononen 2008-12-08 16:44:44 UTC
Working on this now. Also need to make sure that the Rails project generator uses the jdbc<db> adapters in database.yml 
when it makes sense, i.e. at least for JRuby + Rails 2.2, possibly always for JRuby.
Comment 6 Quality Engineering 2008-12-11 05:59:29 UTC
Integrated into 'main-golden', will be available in build *200812110201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/78191d62ca77
User: Erno Mononen <emononen@netbeans.org>
Log: #138316: Bundle jdbcmysql and jdbcpostgresql adapters
- part 1: enabling use of jdbc-mysql in the rails project wizard
Comment 7 Erno Mononen 2008-12-11 12:26:06 UTC
The necessary drivers and adapters for both MySQL and PostgreSQL are bundled now. The relevant changeset are annotated, 
the last one is 5cb92b996274.
Comment 8 Quality Engineering 2008-12-12 17:31:53 UTC
Integrated into 'main-golden', will be available in build *200812121401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/5646ee5117e8
User: Erno Mononen <emononen@netbeans.org>
Log: #138316: Bundle jdbcmysql and jdbcpostgresql adapters
+ upgraded activerecord-jdbc to 0.9
+ fixed rspec license


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo