Bug 138105 - caret continues to blink in non-active windows
caret continues to blink in non-active windows
Status: RESOLVED DUPLICATE of bug 90371
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
Macintosh Mac OS X
: P3 with 1 vote (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-24 15:52 UTC by kirkstork
Modified: 2008-08-01 08:35 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kirkstork 2008-06-24 15:52:37 UTC
Mac OSX 10.5.3
Java 1.6 framework
Apple's Framework info...
  Version:	12.1.0
  Last Modified:	5/6/08 7:39 AM
  Location:	/System/Library/Frameworks/JavaVM.framework

If multiple editor windows are visible, the caret blinks in both of them.  There should be no active-looking caret
displayed in a window that does not have focus.

Related:  When running a single unit test using shift-F6 focus shifts to the unit test results window, but the caret
continues to blink in the editor window.  The use-case here is -probably- one where the user wishes to make an edit, run
the test, and continue editing base on what is observed in the results window.  Switching focus just because the test
was run breaks this, and is worsened by the fact that the blinking caret suggests you can keep editing.
Comment 1 Petr Chytil 2008-07-24 13:02:11 UTC
reassigning to core/win system for evaluation
Comment 2 David Simonek 2008-07-24 14:10:03 UTC
Passing to editor...
Comment 3 Petr Cyhelsky 2008-07-31 12:24:21 UTC
this is really annoying and should be fixed soon
Comment 4 Vitezslav Stejskal 2008-08-01 08:35:23 UTC
Yet another focus related problem on Mac OS X. I'm sorry this is most likely a JDK problem and there is not much we can
do about it in Netbeans.

*** This issue has been marked as a duplicate of 90371 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo