Bug 13782 - Output window does not show multibyte properly from jsp servlet compilation errors
Output window does not show multibyte properly from jsp servlet compilation e...
Status: CLOSED INVALID
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
Sun Solaris
: P2 (vote)
: 6.x
Assigned To: akemr
ivan
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-20 20:34 UTC by Ken Frank
Modified: 2008-12-23 08:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2001-07-20 20:34:34 UTC
Originally bugtraq 4452155
Running in ja locale.

1. Create a servlet using new template and give it a name with mul
tibyte
2. Compile the servlet and set external execution
3. Choose servlet and execute menu item
4. output error window states:
Exception in thread "main" java.lang.NoClassDefFoundError: XXXserv
let
where XXX is some garbage ascii as opposed to showing the multibyt
e properly
as happens in output window when using other modules

a. For example, enter a syntax error in this servlet java code and
 compile,
the output window compile tab shows the name of the file with mult
ibyte properly.

b. Attached are snapshot .rs files of output window of each situat
ion.

5. Java programs should be able to have multibyte as the name of t
he
class (and thus file). In practice, we have seen that the program
that has the "main" routine will not run by java command if it has
 multibyte in its name, although will compile,but other classes of
 a program will.

--> So if the main routine of this servlet is meant to be in the s
ame servlet
program, this would not be a bug, due to the limitations of java c
ommand.

NOTE - this description is just to show the problem, it is not mea
nt to be
a logical user scenario and that main rountine was not added (and 
thus the 
error shown in output window) is not the problem being described.
Comment 1 Jan Zajicek 2001-07-24 14:16:39 UTC
If 5. and comments bellow is true, than this is known issue, please
can it be more deeply investigated from JSP point of view. CCing Pata.
Comment 2 Petr Jiricka 2001-10-18 14:24:14 UTC
What is the known issue mentioned in Jan Zajicek's comment that this 
is related to ? It seems to me that this is not a JSP/servlet-
specific issue, but rather an output window issue, reassigning to 
core.

Also, I can not find the attachment mentioned in Ken's 4a.

I can reproduce this problem also for non-servlet Java classes (build 
200110170100).

Comment 3 Jan Zajicek 2001-10-19 08:58:35 UTC
Passing to the OW guys.
Comment 4 akemr 2001-10-19 09:16:52 UTC
This is JDK issue - I tested it using jdk1.3 and 1.4 from command 
line.
Compiler (javac) works correctly, but executor (java) doesn't.
Comment 5 Ken Frank 2001-12-25 01:40:56 UTC
Can someone detail in bug report reasons for the bug being closed ?
I'd seen reference below to jdk issue but no reference to existing or
new
jdk bug that would explain bug behavior. I'm not saying bug should not
be closed,
but it will help our testing efforts to know why and also for i18n
release notes.

ken.frank@sun.com  
Comment 6 Jan Chalupa 2002-01-07 15:41:45 UTC
Ok, if it's a JDK issue, can anyone provide the JDC bug number, or at 
least a test case that demonstrates the problem in JDK. Thanks.
Comment 7 akemr 2002-01-08 07:18:09 UTC
See BugParade: #4193134, #4051149..
Comment 8 Quality Engineering 2003-07-01 16:04:03 UTC
Resolved for 3.4.x or earlier, no new info since then -> verified.

Comment 9 Quality Engineering 2003-07-01 16:30:40 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.
Comment 10 Quality Engineering 2008-12-23 08:29:57 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo