Bug 137533 - Quick Search - first typed letter is selected
Quick Search - first typed letter is selected
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
6.x
All Mac OS X
: P2 (vote)
: 6.x
Assigned To: t_h
issues@platform
http://wiki.netbeans.org/TS_65_Window...
testspec 65fixes1-verified
:
: 151099 151643 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-18 08:49 UTC by Jaromir Uhrik
Modified: 2009-02-19 22:53 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2008-06-18 08:49:46 UTC
Product Version: NetBeans IDE Dev (Build 200806180005)
Java: 1.5.0_13; Java HotSpot(TM) Client VM 1.5.0_13-119
System: Mac OS X version 10.5.2 running on i386; MacRoman; en_US (nb)

Steps to reproduce:
-select explorer by Ctrl+1
-let's assume that you want to jump on the e.g. Main quickly so try to type 'Main'  
-->> when the first letter is typed the quicksearch appears and the letter is selected there. So that when the second
letter is typed then the selected text is replaced by this letter (e.g. typing 'Main' causes 'ain'). On Win XP it works
fine - I can see this issue only on my Mac.
Comment 1 johnsi 2008-06-19 15:50:58 UTC
I get this issue too

Product Version: NetBeans IDE 6.1 (Build 200805300101)
Java: 1.5.0_13; Java HotSpot(TM) Client VM 1.5.0_13-119
System: Mac OS X version 10.5.3 running on i386; MacRoman; en_US (nb)
Comment 2 Max Sauer 2008-09-25 21:24:12 UTC
Happens on my mac too, very annoying.
---
Product Version: NetBeans IDE Dev (Build 20080908112802)
Java: 1.6.0_04-dp; Java HotSpot(TM) 64-Bit Server VM 1.6.0_04-b12-45-optimized
System: Mac OS X version 10.5.5 running on x86_64; MacRoman; en_US (nb)
Comment 3 Vladimir Kvashin 2008-10-02 12:35:50 UTC
Happens on my Mac; makes search extremely inconvenient.
Comment 4 Vladimir Kvashin 2008-10-02 12:38:33 UTC
Sorry, forgot to add version info. Here it is
Product Version         = NetBeans IDE Dev (Build 080930)
Operating System        = Mac OS X version 10.5.2 running on i386
Java; VM; Vendor        = 1.5.0_13; Java HotSpot(TM) Server VM 1.5.0_13-119; Apple Inc.
Runtime                 = Java(TM) 2 Runtime Environment, Standard Edition 1.5.0_13-b05-237
Comment 5 Lukas Hasik 2008-10-23 09:24:31 UTC
*** Issue 151099 has been marked as a duplicate of this issue. ***
Comment 6 Lukas Hasik 2008-10-29 12:39:32 UTC
*** Issue 151643 has been marked as a duplicate of this issue. ***
Comment 7 Marian Mirilovic 2008-11-04 12:20:00 UTC
Mentioned on NB 6.5 CA survey, 3 votes, 2 duplicates.
Comment 8 t_h 2008-11-06 16:40:42 UTC
f5b216a718cb
Comment 9 Quality Engineering 2008-11-07 05:02:36 UTC
Integrated into 'main-golden', will be available in build *200811070201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/f5b216a718cb
User: Tomas Holy <t_h@netbeans.org>
Log: #137533: Quick Search - first typed letter is selected
Comment 10 Petr Chytil 2008-11-19 13:46:38 UTC
verified in:

Product Version: NetBeans IDE Dev (Build 200811180201)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.5 running on i386; MacRoman; en_US (nb)
Userdir: /Users/petr/.netbeans/dev
Comment 11 pslechta 2008-11-19 15:40:37 UTC
The fix has been backported into release65_fixes.

http://hg.netbeans.org/release65_fixes/rev/40a485ef524d
Comment 12 Petr Chytil 2008-12-02 09:44:26 UTC
verified in 6.5 with Patch 1:

Product Version: NetBeans IDE 6.5 (Build 200811100001)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.5 running on i386; MacRoman; en_US (nb)
Userdir: /Users/petr/.netbeans/6.5


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo