Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 137450 - Appearance of highlighting of top level categories in Option panel is not compliant with Nimbus
Appearance of highlighting of top level categories in Option panel is not com...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
All Solaris
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
: L&F
: 136906 (view as bug list)
Depends on:
Blocks: 131305
  Show dependency treegraph
 
Reported: 2008-06-17 15:33 UTC by Ondrej Langr
Modified: 2008-12-22 11:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
current appearance of highlighting (3.33 KB, image/jpeg)
2008-06-17 15:35 UTC, Ondrej Langr
Details
correct visual appearance (defined in Nimbus specification) (52.36 KB, image/jpeg)
2008-06-17 15:37 UTC, Ondrej Langr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ondrej Langr 2008-06-17 15:33:16 UTC
For the current VS desired appearance see the attachments.
Comment 1 Ondrej Langr 2008-06-17 15:35:31 UTC
Created attachment 62936 [details]
current appearance of highlighting
Comment 2 Ondrej Langr 2008-06-17 15:37:41 UTC
Created attachment 62937 [details]
correct visual appearance (defined in Nimbus specification)
Comment 3 Stanislav Aubrecht 2008-08-21 12:14:30 UTC
does it mean that selection color is hard-coded to #adcadc
Comment 4 Ondrej Langr 2008-08-22 10:07:11 UTC
Ideally (i.e. if the implementation is reasonable), the gradient version should be used. If implementation of the
gradient would be inefficient/time-consuming, I'd say the hardcoded color is OK too, but we are still only talking about
Nimbus here. For "over" effect, 50% transparency should be used (this corresponds to hardcoded #D6E4ED assuming the
underlying color is pure white).

For windows & mac OS X, I would suggest some color changes too, but that probably does not belong to this issue. 
Comment 5 Jiri Skrivanek 2008-09-04 15:18:50 UTC
*** Issue 136906 has been marked as a duplicate of this issue. ***
Comment 6 Stanislav Aubrecht 2008-09-18 15:17:11 UTC
fixed

34652f5691e5
Comment 7 Quality Engineering 2008-09-20 05:35:12 UTC
Integrated into 'main-golden', will be available in build *200809200201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/34652f5691e5
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #137450 - better looking option categories on nimbus & gtk


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo