Bug 137405 - Unresolved Java classes if groovy class is open on IDE start
Unresolved Java classes if groovy class is open on IDE start
Status: VERIFIED FIXED
Product: groovy
Classification: Unclassified
Component: Editor
6.x
All All
: P1 (vote)
: 6.x
Assigned To: martin_adamek
issues@groovy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-17 10:08 UTC by martin_adamek
Modified: 2008-10-30 14:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description martin_adamek 2008-06-17 10:08:51 UTC
Groovy parser invoked by opened editor while IDE is starting fails to recognize Java classes referenced from Groovy source because Java scanning is not 
finished. It might be random.
Comment 1 martin_adamek 2008-06-25 22:09:56 UTC

*** This issue has been marked as a duplicate of 138067 ***
Comment 2 martin_adamek 2008-06-25 22:13:49 UTC
Sorry, it's not duplicate
Comment 3 martin_adamek 2008-06-25 22:19:50 UTC
Fixed in #ca9c2533a14a
Comment 4 Lukas Jungmann 2008-06-27 09:27:36 UTC
v. in trunk, feel free to push this also to M1...

Thanks
Comment 5 martin_adamek 2008-06-27 09:55:00 UTC
Fixed also in M1.
http://hg.netbeans.org/release65_m1/rev/7e518329fc70
Comment 6 martin_adamek 2008-06-27 09:55:33 UTC
Fixed also in M1.
http://hg.netbeans.org/release65_m1/rev/d31f6483d7fa
Comment 7 martin_adamek 2008-06-27 09:55:58 UTC
Sorry, last comment doesn't belong here.
Comment 8 Quality Engineering 2008-06-27 16:36:04 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #285 build
Changeset: http://hg.netbeans.org/main/rev/ca9c2533a14a
User: Martin Adamek <martin_adamek@netbeans.org>
Log: #137405: Unresolved Java classes if groovy class is open on IDE start
Comment 9 Lukas Jungmann 2008-09-29 14:24:36 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo