Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 136699 - functional regression: no more Fortran autoindenting
functional regression: no more Fortran autoindenting
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
5.x
All All
: P3 (vote)
: 6.x
Assigned To: Alexander Simon
issues@cnd
fortran 61fixes4-fixed, release601_fi...
:
Depends on:
Blocks: 145858
  Show dependency treegraph
 
Reported: 2008-06-06 21:15 UTC by Thomas Preisler
Modified: 2008-12-09 13:37 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Preisler 2008-06-06 21:15:58 UTC
From CR 6539078:

In the Sun Studio 12 IDE, when you type in Fortran source code,
there seems to be no automatic indenting of the source code to
reflect either DO-loop or IF-block structure.

This appears to be a functional regression from the Sun Studio 11
IDE, whose behavior I will now describe.

In Studio 11, if I choose

   "File" -> "New..."

and then

   "Templates" -> "Fortran Files" -> "Fortran File (Free Format)"

I get

   |PRINT*,"Hello World"
   |END

(The vertical bars are there simply to indicate the left edge of
the window.)

I can then input the following text between those two, initial
statements:

   |do i = 1, 10
   |if ( i < 5 ) then
   |write(6,*) "mistake 1
   |else
   |write(6,*) mistake 2"
   |end if
   |end do

After each carriage return, the newly entered line is automatically
indented to reflect DO and IF block structures.  Indeed, with the
"end if" statement, the line is indented as soon as the "end if" is
entered (that is, even before the carriage return is entered).  The
final text looks like this:

   |PRINT*,"Hello World"
   |do i = 1, 10
   |    if ( i < 5 ) then
   |        write(6,*) "mistake 1
   |    else
   |        write(6,*) mistake 2"
   |    end if
   |end do
   |END
Comment 1 Alexander Simon 2008-08-21 15:08:08 UTC
fixed, change set :
http://hg.netbeans.org/main/rev/5bef9294692b
Comment 2 Thomas Preisler 2008-08-21 17:09:24 UTC
See also escalation 1-24453895 / CR# 6737403
Comment 3 Quality Engineering 2008-08-22 05:59:31 UTC
Integrated into 'main-golden', available in build *200808220201* on http://bits.netbeans.org/dev/nightly/
Changeset: http://hg.netbeans.org/main/rev/5bef9294692b
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed: IZ#136699:functional regression: no more Fortran autoindenting
Comment 4 Alexander Simon 2008-08-25 12:11:13 UTC
Change set:
http://hg.netbeans.org/main/rev/9bc9805c4b86
make inner class privet (remove API changes)
Comment 5 Quality Engineering 2008-08-25 17:21:09 UTC
Integrated into 'main-golden', available in build *200808251401* on http://bits.netbeans.org/dev/nightly/
Changeset: http://hg.netbeans.org/main/rev/9bc9805c4b86
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed: IZ#136699:functional regression: no more Fortran autoindenting
- make inner class privet (remove API changes)
Comment 6 Karthikeyan Rajeswaran 2008-09-17 00:44:22 UTC
The fix has been backported to release551_fixes branch:

Checking in FFormatSupport.java;
/cvs/cnd/core/src/org/netbeans/modules/cnd/editor/fortran/Attic/FFormatSupport.java,v  <--  FFormatSupport.java
new revision: 1.1.2.3.6.1; previous revision: 1.1.2.3
done
Checking in FFormatter.java;
/cvs/cnd/core/src/org/netbeans/modules/cnd/editor/fortran/Attic/FFormatter.java,v  <--  FFormatter.java
new revision: 1.1.2.3.6.1; previous revision: 1.1.2.3
done
Checking in FKit.java;
/cvs/cnd/core/src/org/netbeans/modules/cnd/editor/fortran/Attic/FKit.java,v  <--  FKit.java
new revision: 1.1.2.2.6.1; previous revision: 1.1.2.2
done
Comment 7 pgebauer 2008-09-24 10:49:12 UTC
This issue is part of 61patch4. Could QE verified the fix in the trunk by 25-Sep-08?
Comment 8 soldatov 2008-09-24 13:38:18 UTC
Into patch should be added fixes from issue 147689 and issue 147688 also. Because if you will switch on Fortran
autoindenting, then these 2 new problems appear.
In NB6.5 trunk Fortran autoindenting works correctly.
Comment 9 Alexander Pepin 2008-09-24 14:20:49 UTC
verified in NB6.5 build 20080924
Comment 10 Alexander Pepin 2008-09-24 14:21:23 UTC
verified
Comment 11 Karthikeyan Rajeswaran 2008-10-01 18:52:43 UTC
The fix has been ported into the release61_fixes repository.
http://hg.netbeans.org/release61_fixes/rev/0ce771bf3f24
Comment 12 Alexander Pepin 2008-10-08 14:18:01 UTC
verified in patch4
Comment 13 Karthikeyan Rajeswaran 2008-10-08 18:06:02 UTC
The fix for 147688 , 147689, 136699 and 145858 have been backported to release601_fixes branch.

For details, please refer to:
   ------- Additional comments from krajeswaran Wed Oct 8 17:00:03 +0000 2008 -------
in issue 147688
Comment 14 Alexander Pepin 2008-11-11 14:53:25 UTC
verified in 5.5.1 with manually installed nbms from PromoG1Patch4


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo