Bug 136601 - Deadlock in CloneableEditor$DoInitialize.initVisual during commit validation
Deadlock in CloneableEditor$DoInitialize.initVisual during commit validation
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Text
6.x
All All
: P1 (vote)
: 6.x
Assigned To: mslama
issues@platform
http://konik-z2.czech.sun.com:8080/hu...
: RANDOM, THREAD
: 136033 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 21:43 UTC by Jesse Glick
Modified: 2008-12-22 10:59 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (15.95 KB, text/plain)
2008-06-05 21:45 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2008-06-05 21:43:50 UTC
Will attach thread dump.
Comment 1 Jesse Glick 2008-06-05 21:45:23 UTC
Created attachment 62438 [details]
Thread dump
Comment 2 Jesse Glick 2008-06-06 15:18:04 UTC
Failed again during 733, thread dumps looks the same.
Comment 3 mslama 2008-06-09 15:25:30 UTC
I am investigating. It does not seem to be deadlock. CloneableEditor blocks AWT thread - it looks like first phase of
editor initialization failed. But there is no thread for first phase, no exception log. "Refresh Editor Context" just
accidentally waits for blocked AWT thread. I will add logging to see what happens with first editor initialization phase
and enable logging just for commit validation.
Comment 4 mslama 2008-06-10 10:22:17 UTC
Added logging 2c6d217d573a
Comment 6 mslama 2008-06-12 17:20:49 UTC
Progress: In this case doc variable is null after call of notifyAll. It can happen when document is closed during
opening. It can happen during test because document is opened/closed immediatelly.
Comment 7 mslama 2008-06-13 11:34:41 UTC
Fixed fe15228c9896.

One fix is to change condition to break wait loop in initDocument. Other fix is to avoid recursive call of initVisual.

Logging is changed to Level.FINE and enabled in commit-validation to monitor behavior of CloneableEditor in
commit-validation.
Comment 8 mslama 2008-06-13 11:37:12 UTC
Condition is change to make sure that wait is not entered when document is closed during opening CloneableEditor.
Comment 9 mslama 2008-06-17 17:32:15 UTC
*** Issue 136033 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo