Bug 136596 - Netbeans hang for several minutes when doing indenting while compiling.
Netbeans hang for several minutes when doing indenting while compiling.
Status: RESOLVED DUPLICATE of bug 140780
Product: java
Classification: Unclassified
Component: Editor
6.x
All Windows XP x64
: P3 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
: PERFORMANCE, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 20:23 UTC by mjensen
Modified: 2008-08-13 10:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread Dump of where Netbeans hangs for 5-10 minutes (21.84 KB, text/plain)
2008-06-07 17:07 UTC, mjensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mjensen 2008-06-05 20:23:57 UTC
Netbeans automatically initiate what is shown at the bottom of the screen as 'compiling', and it seemingly does 
through the .jar files that I have pointed it to. (quite a few).

Everytime it is actually running the 'compiling' task, if I hit the tab key, which I have associated to use the re-
indent current line or selection (found at : tools, options, keymap, other, Re-indent current line or selection) 
netbeans hang for several minutes without performing the indent or progressing with the 'compiling' task.

(Please note that when I say compiling I dont mean compiling the source code but the netbeans automatic 'compiling' 
feature that looks that jars specified in the libraries).

Product Version: NetBeans IDE 6.1 (Build 200804211638)
Java: 1.5.0_15; Java HotSpot(TM) Client VM 1.5.0_15-b04
System: Windows 2003 version 5.2 running on x86; Cp1252; en_US (nb)

I use windows xp 64 bit.
Comment 1 Vitezslav Stejskal 2008-06-07 12:45:58 UTC
Could you please generate a full thread dump, so that we could see what is happening in the IDE? See
http://wiki.netbeans.org/GenerateThreadDump for details. Thanks
Comment 2 mjensen 2008-06-07 17:07:47 UTC
Created attachment 62521 [details]
Thread Dump of where Netbeans hangs for 5-10 minutes
Comment 3 Petr Dvorak 2008-07-09 12:12:52 UTC
There is no pending clarification request, so I think the issue is not INCOMPLETE anymore (removing the keyword).

Furthermore, the issue is reproducible in dev build (200807090008). Steps to reproduce:

0. Download NB sources, "ant", start NB with a clean userdir  (this is what every NB developer have already done,
vstejskal, you can skip this step)

1. Go to Tools>Options>Keymaps, expand the Other node, set "Re-indent Current Line or Selection" shortcut to Ctrl+Alt+M
(this one is free)
2. Get ready to perform following steps fast enough (have an energy drink, or something...)
3. Open "java.editor" module from the NB sources - this is the one we can miss if something goes wrong...
4. While scanning/indexing/compiling is in progress, open some java file (that is not opened yet in the editor) from
some package, go to some line inside the first method you find, press Ctrl+Alt+M (if IDE goes back alive too fast, press
it again on the line bellow) and wait until the NB starts reacting or dies (**from 3 attempts to reproduce the issue
once IDE just... died with no announcement... - IMHO quite serious...**).
Comment 4 Jan Becicka 2008-07-14 12:31:09 UTC
Seems to be java/editor or java/source issue
Comment 5 Jan Lahoda 2008-07-15 11:54:03 UTC
I assume that by "died with no announcement" you mean JDK crash - sorry but this needs to be filled against JDK.
Comment 6 mjensen 2008-07-15 15:46:29 UTC
You write: I assume that by "died with no announcement" you mean JDK crash - sorry but this needs to be filled against 
JDK.

That might be what Joshis experienced, but it was not quite what I reported. 
Comment 7 mjensen 2008-07-15 15:46:37 UTC
You write: I assume that by "died with no announcement" you mean JDK crash - sorry but this needs to be filled against 
JDK.

That might be what Joshis experienced, but it was not quite what I reported.
Comment 8 Jan Becicka 2008-08-13 10:02:37 UTC

*** This issue has been marked as a duplicate of 140780 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo