Bug 136467 - Interface does not deal with redirected folders
Interface does not deal with redirected folders
Status: RESOLVED DUPLICATE of bug 46813
Product: platform
Classification: Unclassified
Component: Filesystems
6.x
All Windows XP
: P3 (vote)
: 6.x
Assigned To: Jiri Skrivanek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 14:44 UTC by m4g3
Modified: 2008-12-22 10:58 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m4g3 2008-06-04 14:44:07 UTC
We use roaming profiles with redirected folders such as My documents, my Music, etc to a mapped network drive. When
creating new project in the New Project dialog box the following message is shown "Project Folder is not a valid path"
but Project Location and Project Folder fields above show the correct paths (i.e. \\server\username\NetBeansProjects)
Comment 1 Jana Maleckova 2008-06-04 15:17:17 UTC
reassign to project for evaluation
Comment 2 Milos Kleint 2008-06-05 07:39:25 UTC
reassigning to filesystems.
 Do I understand it correctly that \\server notation on windows is not supported by filesystems?
Comment 3 Jiri Skrivanek 2008-06-05 09:05:00 UTC
UNC paths are recognized in recent 6.5 development builds. For 6.1, please, map your path
\\server\username\NetBeansProjects as a network drive.

*** This issue has been marked as a duplicate of 46813 ***
Comment 4 m4g3 2008-06-05 09:37:35 UTC
Can i use windows env variables (like %HOMEPATH% or %HOMEDRIVE%) in netbeans.conf file? If so how? So far i only know
that one can use $HOME for users default profile path (this might a way around the problem for me)
Comment 5 Jiri Skrivanek 2008-06-05 09:46:00 UTC
You can use "--userdir <whatever path>" when starting IDE.
Comment 6 m4g3 2008-06-05 12:17:16 UTC
Hmm that would mean creating custom shortcuts/program files entries for all of the users. Istn't there a way to use env
vars in the global netbeans.conf file? That would be easier
Comment 7 Jiri Skrivanek 2008-06-05 14:01:37 UTC
AFAIK, properties like %HOMEPATH% or %HOMEDRIVE% are not resolved in netbeans.conf. Just $HOME is available.
Comment 8 m4g3 2008-06-05 14:43:31 UTC
:( oki doki thx. Would it be possible to consider use of system env variables for futore releases?
Comment 9 Jiri Skrivanek 2008-06-05 14:54:04 UTC
If you really need it, you can file enhancement issue against core/code component.
Comment 10 m4g3 2008-06-05 15:07:38 UTC
Thx it is done :)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo