Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 136448 - Refactoring doesn't work.
Refactoring doesn't work.
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P1 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
61fixes2-fixed
:
: 136477 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 09:42 UTC by Peter Pis
Modified: 2008-07-10 15:08 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Pis 2008-06-04 09:42:47 UTC
Product Version: NetBeans IDE Dev (Build 200806040005)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)
Userdir: D:\ide\65\user

Steps:
1. Open project (nb module) under HG control, "Mercurial | Status" on project root.
2. Select some package that contains more files and invoke "Refactoring | Rename" action from "Projects" view.
3. Proceed with refactoring dialog.
4. After refactoring only one file is marked as [Copied] and others are up-to-date.

All files should be treated as [Copied].
Comment 1 Peter Pis 2008-06-04 21:29:05 UTC
*** Issue 136477 has been marked as a duplicate of this issue. ***
Comment 2 Tomas Stupka 2008-06-04 23:38:25 UTC
fixed

73248809fc93
Comment 3 Peter Pis 2008-06-05 12:26:00 UTC
Verified in trunk.
Comment 4 rbalada 2008-06-05 13:44:18 UTC
I've transplanted the changeset http://hg.netbeans.org/main/rev/73248809fc93 into release61_fixes repository as
http://hg.netbeans.org/release61_fixes/rev/d9cb73a9c0bc
Comment 5 Peter Pis 2008-06-19 10:59:55 UTC
Verified with patch2.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo