Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 136307 - initial deploy of Ent App too slow.
initial deploy of Ent App too slow.
Status: RESOLVED INCOMPLETE
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
61fixes2-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 18:09 UTC by Vince Kraemer
Modified: 2010-01-28 03:40 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vince Kraemer 2008-06-02 18:09:36 UTC
See thread: http://www.netbeans.org/servlets/BrowseList?list=nbj2ee&by=thread&from=849056

creating the initial deployment directory is the bottleneck.
Comment 1 Vince Kraemer 2008-06-03 04:05:54 UTC
http://hg.netbeans.org/main/rev/4161d34008c4

was able to reduce the "copy time" from 1 minute 20 seconds to 6 seconds in my test, based on the seampagination sample.

This needs to get verified by other users and then get rolled into the 6.1 patch 2, if no regressions are found.
Comment 2 Vince Kraemer 2008-06-03 04:30:41 UTC
clarify the details on the issue a bit.
Comment 3 henoc 2008-06-03 12:28:52 UTC
Tested with success (9 minutes deployment reduced to some few seconds..)
Comment 4 pslechta 2008-06-04 13:37:42 UTC
The fix has been ported into the release61_fixes repository.

http://hg.netbeans.org/release61_fixes/rev/c4f231de4d46
Comment 5 cy6ergn0m 2010-01-27 09:33:43 UTC
The regression for this bug was found in NetBeans 6.7 with EAR-applications. Deployment takes ~6 minutes. The bottleneck is near deployment directory construction (Initial deploying).
Comment 6 Vince Kraemer 2010-01-27 15:37:14 UTC
(In reply to comment #5)
> The regression for this bug was found in NetBeans 6.7 with EAR-applications.
> Deployment takes ~6 minutes. The bottleneck is near deployment directory
> construction (Initial deploying).

Please provide enough details about the situation so that we can make progress on analyzing/resolving this.  You may want to open a new issue.
Comment 7 cy6ergn0m 2010-01-28 03:40:06 UTC
The facts:
1. The problem is 100% reproducible. 
2. My "Enterprise Application" project contains one web module, one EJB-module and both uses the same project as shared library.
3. If i use "deploy on save" option, this bug is irrelevant.
4. At the first Deploy this bug does not occurs, but if i click Deploy at second time, it will work very slow. There is a workaround for this: if i use "Clean and Build" for this project and then "Deploy" every time, it work much faster.
5. Size of the result .ear file is ~25M
6. I use glassfish v2.1 with netbeans 6.7 at Solaris\sparc
7. JavaServerFacer framework enabled for web module that included to EAR-application and some JPA's EJB beans are registered in EJB-module.
8. I can't check it with NetBeans 6.8 because JSF1.2 projects is no longer supported by netbeans and it can't be built.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo