Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 136269 - Check Package-Dependencies when installing new plugins
Check Package-Dependencies when installing new plugins
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on:
Blocks: 135512
  Show dependency treegraph
 
Reported: 2008-06-02 14:41 UTC by Jiri Rechtacek
Modified: 2008-06-24 15:27 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
proposed patch (3.63 KB, patch)
2008-06-06 18:51 UTC, Jiri Rechtacek
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2008-06-02 14:41:28 UTC
Autoupdate Services doesn't check OpenIDE-Module-Package-Dependencies when installing plugins. Autoupdate should care
about such Package-Dependencies in same way as module-module dependencies.
Comment 1 Jesse Glick 2008-06-02 18:17:41 UTC
I would rather suggest to deprecate OIDE-M-Package-Dependencies. It was always a tag of last resort. If we fix modules
to bundle the libraries they need, we should not have to use it again.
Comment 2 Jiri Rechtacek 2008-06-06 18:51:28 UTC
Created attachment 62494 [details]
proposed patch
Comment 3 Jiri Rechtacek 2008-06-06 18:58:12 UTC
Jesse, my proposed patch contains making a one method public in the currently friend contract AU->bootstrap. Jarda has
confirmed that will not be a subject of API review. Do you agree? Thanks
Comment 4 Jiri Rechtacek 2008-06-09 12:40:27 UTC
fixed in a4486ee05e5c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo