Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 136249 - [GTK] Appearance of buttons in the window titlebars is not Nimbus compliant
[GTK] Appearance of buttons in the window titlebars is not Nimbus compliant
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
Sun All
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
fix-in-65
: L&F, SIMPLEFIX
: 135713 (view as bug list)
Depends on:
Blocks: 131305
  Show dependency treegraph
 
Reported: 2008-06-02 12:30 UTC by Ondrej Langr
Modified: 2008-12-22 10:54 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nimbus non-compliant elements ... (52.77 KB, image/png)
2008-06-02 12:50 UTC, Ondrej Langr
Details
Correct NIMBUS images for window titlebar icons (9.54 KB, application/x-compressed)
2008-08-18 19:43 UTC, Ondrej Langr
Details
current image which has no replacement in the attached zip file (330 bytes, image/png)
2008-08-23 17:05 UTC, Stanislav Aubrecht
Details
nimbus titlebar buttons (17.07 KB, application/x-compressed)
2008-09-08 10:17 UTC, Ondrej Langr
Details
close button 14x14px (1.57 KB, application/x-compressed)
2008-09-10 12:41 UTC, Ondrej Langr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ondrej Langr 2008-06-02 12:30:10 UTC
Elements for closing and docking the window in NetBeans are not Nimbus compliant on Nimbus L&F.
Comment 1 Ondrej Langr 2008-06-02 12:50:48 UTC
Created attachment 62243 [details]
nimbus non-compliant elements ...
Comment 2 David Simonek 2008-06-18 09:35:34 UTC
Passing to Marek who works on Nimbus.
Comment 3 Ondrej Langr 2008-08-15 13:42:49 UTC
Plus there is another problem. The close graphics are different on the editor tabs and on other windows. All close
buttons should (obviously) be on one L&F the same.
Comment 4 Ondrej Langr 2008-08-18 19:41:35 UTC
Attaching the correct images. Assuming this would be SIMPLEFIX as it only means changing the graphics. Can we make it
for 6.5?
Comment 5 Ondrej Langr 2008-08-18 19:43:08 UTC
Created attachment 67731 [details]
Correct NIMBUS images for window titlebar icons
Comment 6 Stanislav Aubrecht 2008-08-21 15:04:51 UTC
well, it is simplefix as long as you don't mind having those images for all GTK themes, not just the nimbus one...
Comment 7 Ondrej Langr 2008-08-22 11:43:07 UTC
Agreed, it is totally OK to have them for all GTK L&Fs. 

The images are done so that they will even work for inverse themes. Further, the sun's strategic theme is nimbus and
that is the one that should look perfect. Other GTK themes need to be usable, but we're not able to create separate
graphics for all of them.
Comment 8 Stanislav Aubrecht 2008-08-23 17:02:43 UTC
it seems there are some icons missing in the zip, for example the current gtk_popup_rollover.png doesn't match the new
gtk_popup_enabled.png from the zip file.
Comment 9 Stanislav Aubrecht 2008-08-23 17:05:32 UTC
Created attachment 68161 [details]
current image which has no replacement in the attached zip file
Comment 10 Ondrej Langr 2008-08-25 08:54:50 UTC
I think solaris_popup_enabled.png from the zipfile is replacement for this graphic. The rollover and pressed states for
this graphics are not included because they should not be needed (AFAIK, these states are behavior of the buttons and do
not change the graphics on them). So even for the other symbols, these states are included only as a preview how it will
look when implemented. 
Comment 11 Ondrej Langr 2008-09-02 14:11:39 UTC
*** Issue 135713 has been marked as a duplicate of this issue. ***
Comment 12 Stanislav Aubrecht 2008-09-02 17:11:29 UTC
these buttons are too small to use default button borders provided by some look and feels. so we need the borders and
mouse-over effects defined as separate images.
so please provide the missing images to fix this issue
Comment 13 Ondrej Langr 2008-09-08 10:16:11 UTC
I see. The requested button graphics are attached. 
Comment 14 Ondrej Langr 2008-09-08 10:17:31 UTC
Created attachment 69290 [details]
nimbus titlebar buttons
Comment 15 Ondrej Langr 2008-09-10 12:40:29 UTC
14x14px close buttons (for usage on tabs) were requested as they were missing in the previous file.

Now attached. 
Comment 16 Ondrej Langr 2008-09-10 12:41:19 UTC
Created attachment 69524 [details]
close button 14x14px
Comment 17 Stanislav Aubrecht 2008-09-10 15:36:49 UTC
fixed

0d94db276825
Comment 18 Quality Engineering 2008-09-11 17:33:22 UTC
Integrated into 'main-golden', will be available in build *200809111401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0d94db276825
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #136249 - [GTK] Appearance of buttons in the window titlebars is not Nimbus compliant


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo