Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 136212 - Editor locked up
Editor locked up
Status: RESOLVED DUPLICATE of bug 119617
Product: java
Classification: Unclassified
Component: Javadoc
6.x
Macintosh All
: P2 (vote)
: TBD
Assigned To: Jan Pokorsky
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-31 08:01 UTC by John Baker
Modified: 2008-06-03 09:19 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (52.84 KB, text/plain)
2008-05-31 08:02 UTC, John Baker
Details
thread dump (13.24 KB, text/plain)
2008-06-03 01:59 UTC, John Baker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Baker 2008-05-31 08:01:09 UTC
Product Version: NetBeans IDE 6.1 (Build 200804211638)
Java: 1.5.0_13; Java HotSpot(TM) Client VM 1.5.0_13-121
System: Mac OS X version 10.4.11 running on i386; MacRoman; en_US (nb)
Userdir: /Users/test/.netbeans/6.1

While editing, the editor locked up.

I'll attach messages.log
Comment 1 John Baker 2008-05-31 08:02:50 UTC
Created attachment 62203 [details]
messages.log
Comment 2 Jiri Prox 2008-06-02 08:50:19 UTC
The exception comes from javadoc -> reassigning

Can you attach the threaddump of locked ide?  This exception should not cause deadlock.
Comment 3 Jan Pokorsky 2008-06-02 09:23:45 UTC
Yes, please attach the thread dump here if it occurs again (http://wiki.netbeans.org/GenerateThreadDump).

The exception in messages.log is a duplicate of issue #130987.
Comment 4 John Baker 2008-06-03 00:11:08 UTC
Could this be keyboard focus problem with Apple JDK 1.5 ?
If I invoke Find Usages then return, the editor is usable again

See comments towards the end of http://weblogs.java.net/blog/joshy/archive/2005/11/netbeans_on_mac.html
Comment 5 John Baker 2008-06-03 01:59:16 UTC
Created attachment 62293 [details]
thread dump
Comment 6 Jan Pokorsky 2008-06-03 09:19:55 UTC
Yes, it seems to be related to focus issues. The thread dump contains no dead lock. It is most likely a duplicate of
issue #119617 if invoking Find Usages helped.

*** This issue has been marked as a duplicate of 119617 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo