Bug 136134 - I18N - character encoding problem
I18N - character encoding problem
Status: RESOLVED WONTFIX
Product: webservices
Classification: Unclassified
Component: JAX-WS
6.x
All Windows XP
: P3 (vote)
: 7.0
Assigned To: Denis Anisimov
issues@webservices
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 08:13 UTC by orhan
Modified: 2010-10-26 11:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
wsdl file (15.63 KB, application/x-compressed)
2008-05-30 08:14 UTC, orhan
Details
Generated source file (11.29 KB, text/plain)
2008-05-30 08:16 UTC, orhan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description orhan 2008-05-30 08:13:58 UTC
While generating code from wsdl schemas. Netbeans generates wrong characters. I am getting these errors.

D:\dev\workspace\netbeans\SaglikNet\DesktopApplication1\build\generated\wsimport\client\org\hl7\v3\AD.java:114: warning:
unmappable character for encoding UTF-8
    protected Boolean ?sNotOrdered;

and when i build the project it generates the code from scratch and modifies my fix.

how to reproduce
change your localisation to Turkey/Turkish from control panel. And use the wsdl file (i will add it as an attachment) i
attached. The problem is Turkish has a spotless 'i' (ı) and 'I' (İ) with spot.
Comment 1 orhan 2008-05-30 08:14:38 UTC
Created attachment 62152 [details]
wsdl file
Comment 2 orhan 2008-05-30 08:16:30 UTC
Created attachment 62153 [details]
Generated source file
Comment 3 Ken Frank 2008-06-27 16:49:51 UTC
there have been other issues related to use of Turkish letter i
as mentioned below - perhaps these can give info to developers about this -
search on word Turkish in issue summaries.

ken.frank@sun.com
Comment 4 Ken Frank 2008-07-26 16:19:39 UTC
orhan,

can you try it using jdk6, if not already ? I have heard that in 
some cases it helps for this situation.

ken.frank@sun.com
Comment 5 orhan 2008-07-28 07:24:36 UTC
I am using JDK 6. 
the problem is  toLowerCase and toUpperCase functions converts i to İ (I with spot).
While generating java source "toLowerCase" must be used as "toLowerCase(Locale.ENGLISH)"
Comment 6 Milan Kuchtiak 2008-11-28 11:21:54 UTC
One of the issue belongs likely to JAX-WS runtime (generating invalid sources).

Another issue is that Build (or Clean & Build) replaces user modification. One of the solution would be to enable
generate JAX-WS classes to regular sources root (e.g. src/java)

The workaround now is to copy the sources you've modified from build/generated/wsimport/client to java/src directory.
(Of course, the package name must be preserved)
Comment 7 Denis Anisimov 2010-10-26 11:56:21 UTC
The original problem is inside wsimport external utility. 
It should be fixed there.

The IDE could just provide workaround which is not good.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo