Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 136080 - Canceling Mercurial Tasks leaves hg process running
Canceling Mercurial Tasks leaves hg process running
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
PLAN
:
: 178425 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 12:48 UTC by John Rice
Modified: 2010-04-14 04:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Rice 2008-05-29 12:48:01 UTC
Canceling mercurial tasks in the IDE appears to work, but the hg.exe process continues to run.

Under Unix the canceling invokes Process.destroy which kills the invoked python shell and hg command cleanly. Under
Windows there is no parent child process relationship and so canceling the shell that invoked the command does not kill
the Hg.exe process.

http://bugs.sun.com/view_bug.do?bug_id=4770092
Comment 1 Ondrej Vrabec 2009-12-10 06:56:04 UTC
*** Bug 178425 has been marked as a duplicate of this bug. ***
Comment 2 Ondrej Vrabec 2010-04-13 12:38:44 UTC
fix: http://hg.netbeans.org/cdev/rev/be8e46f7bf28
Comment 3 Quality Engineering 2010-04-14 04:43:55 UTC
Integrated into 'main-golden', will be available in build *201004140201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/be8e46f7bf28
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #136080 - Canceling Mercurial Tasks leaves hg process running


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo