Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 136017 - Visual indication that a plugin is of a commercial kind
Visual indication that a plugin is of a commercial kind
Status: RESOLVED DUPLICATE of bug 145901
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P2 (vote)
: TBD
Assigned To: Jiri Rechtacek
issues@platform
http://cocot.dk/nb-plugins.png
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 17:01 UTC by mrmorris
Modified: 2008-10-16 16:55 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mrmorris 2008-05-28 17:01:07 UTC
It is impossible to see up-front from the plugin tab in NB, whether a plugin is open source/free as in free beer or
whether it's a commercial component which requires various monetary support in order to be used. A small green $ icon
could be added as an overlay to signal this to the user. Currently one has to consult the information at
plugins.netbeans.org or simply use trial-n-error.
Comment 1 Geertjan Wielenga 2008-06-01 12:31:37 UTC
I think there should be a new property in the Manifest or somewhere else, to specify whether the plugin is commercial or
free. Then, if the plugin is marked as commercial, a dollar sign would appear in the Plugin Manager for that plugin. I
think this is very important because as more and more plugins become available, it becomes increasingly important to be
able to get this kind of information as quickly as possible -- many people would never install a plugin if they knew it
was basically an advert for some commercial product, hence bumping it up to P2.
Comment 2 Geertjan Wielenga 2008-06-01 12:32:27 UTC
CC-ing J Rechtacek, the Plugin Manager engineer.
Comment 3 Petr Chytil 2008-06-17 16:48:11 UTC
Reassigning to plugin manager.
Comment 4 Jiri Rechtacek 2008-10-16 16:55:20 UTC
I think kind of duplicate of issue 145901.

*** This issue has been marked as a duplicate of 145901 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo