Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 135882 - Rename of a Project under VCS - loss of .hg directory
Rename of a Project under VCS - loss of .hg directory
Status: RESOLVED DUPLICATE of bug 162718
Product: versioncontrol
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
: 142616 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 14:17 UTC by John Rice
Modified: 2009-11-27 01:09 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Rice 2008-05-27 14:17:53 UTC
Rename of a Project under Mercurial control, with option selected to rename directory also, will result in renamed
Project no longer being under Mercurial control. The original projects .hg repository directory is lost in this rename
scenario.

1, Create a new Java project (e.g. JavaAplication1) and initialize it as Mercurial project and Commit
2, Refactor - rename the whole project, select option to rename Directory as well

What we see is the renamed project appears, but it is no longer under Mercurial control. In the process of doing the
copy and rename it appears that the .hg folder is deleted and not copied over to the renamed directory.
Comment 1 John Rice 2008-05-29 12:50:02 UTC
This is a known issue and effects Subversion and CVS. It is to do with th implementation of rename and out of the
mercurial plugin's control.
Comment 2 Peter Pis 2008-09-03 13:07:17 UTC
This is a general problem of all VCS supported by the IDE. Changing to FEATURE.
Comment 3 Peter Pis 2008-09-03 15:50:18 UTC
*** Issue 142616 has been marked as a duplicate of this issue. ***
Comment 4 malfunction84 2008-09-03 16:46:32 UTC
In issue 142616, the problem occurred when renaming a non-version-controlled directory with version-controlled
subdirectories.  So it applies to a broader set of circumstances than just renaming the Project directory.
Comment 5 Ondrej Vrabec 2009-11-27 01:09:20 UTC

*** This bug has been marked as a duplicate of bug 162718 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo