Bug 135812 - CCE: org.netbeans.lib.profiler.ui.components.FilterComponent cannot be cast to javax.swing.JComboBox
CCE: org.netbeans.lib.profiler.ui.components.FilterComponent cannot be cast t...
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jiri Sedlacek
issues@profiler
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: VISUALVM
: 123749 135202 139595 146368 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 14:20 UTC by Jindrich Sedek
Modified: 2008-09-23 08:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.77 KB, text/plain)
2008-05-26 14:20 UTC, Jindrich Sedek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2008-05-26 14:20:09 UTC
Build: NetBeans IDE Dev (Build 200805260002)
VM: Java HotSpot(TM) Client VM, 11.0-b11, Java(TM) SE Runtime Environment, 1.6.0_10-beta-b22
OS: SunOS, 5.11, x86

User Comments: 
Use menu: Profiler / Load HeapDump
load some heapdump file
click classes tab -> CCE is thrown and it's being thrown again and again -> it's impossible to read heap dump
Comment 1 Jindrich Sedek 2008-05-26 14:20:18 UTC
Created attachment 61917 [details]
stacktrace
Comment 2 Tomas Hurka 2008-06-16 14:01:27 UTC
This happens only in JDK6 update 10 on GTK L&F.
Comment 3 Jiri Sedlacek 2008-06-16 16:24:05 UTC
*** Issue 135202 has been marked as a duplicate of this issue. ***
Comment 4 Jiri Sedlacek 2008-06-18 17:02:47 UTC
Fixed for 6.5 M1.

changeset:   84957:a5dcc82812e3
user:        Jiri Sedlacek <jis@netbeans.org>
date:        Wed Jun 18 17:57:35 2008 +0200
summary:     Bugfix #131730 Do not set JComboBox border for custom JComponent on GTK

Note -- "Bugfix #131730" is incorrect, should be "Bugfix #135812"
Comment 5 Tomas Hurka 2008-06-27 16:04:41 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #285 build
Changeset: http://hg.netbeans.org/main/rev/a5dcc82812e3
User: Jiri Sedlacek <jis@netbeans.org>
Log: Bugfix #131730 Do not set JComboBox border for custom JComponent on GTK

Comment 6 Jindrich Sedek 2008-07-03 12:58:30 UTC
verified.

NetBeans IDE Dev (Build 200807030102)
Comment 7 Jiri Sedlacek 2008-07-10 14:32:06 UTC
*** Issue 139595 has been marked as a duplicate of this issue. ***
Comment 8 Jiri Sedlacek 2008-07-22 15:54:43 UTC
*** Issue 123749 has been marked as a duplicate of this issue. ***
Comment 9 Jiri Sedlacek 2008-08-26 15:39:51 UTC
Exactly the same problem occurs when running NetBeans IDE on Nimbus LaF - available since JDK 6 update 10 (currently RC)
on Windows/Linux/Solaris:

java.lang.ClassCastException: org.netbeans.lib.profiler.ui.components.FilterComponent cannot be cast to
javax.swing.JComboBox
	at com.sun.java.swing.plaf.nimbus.ComboBoxEditableState.isInState(ComboBoxEditableState.java:21)
	at com.sun.java.swing.plaf.nimbus.State.isInState(State.java:109)
	at com.sun.java.swing.plaf.nimbus.NimbusStyle.getExtendedState(NimbusStyle.java:1003)
	at com.sun.java.swing.plaf.nimbus.NimbusStyle.getBorderPainter(NimbusStyle.java:886)
	at com.sun.java.swing.plaf.nimbus.SynthPainterImpl.paintBorder(SynthPainterImpl.java:102)
	at com.sun.java.swing.plaf.nimbus.SynthPainterImpl.paintComboBoxBorder(SynthPainterImpl.java:468)
	at javax.swing.plaf.synth.SynthComboBoxUI.paintBorder(SynthComboBoxUI.java:302)
	at javax.swing.plaf.synth.SynthBorder.paintBorder(SynthBorder.java:46)
	at javax.swing.border.CompoundBorder.paintBorder(CompoundBorder.java:94)
	at javax.swing.JComponent.paintBorder(JComponent.java:922)
	at javax.swing.JComponent.paint(JComponent.java:1028)
	[...]

Note that Nimbus LaF isn't used by default, it has to be manually invoked by starting the IDE with --ui
"com.sun.java.swing.plaf.nimbus.NimbusLookAndFeel". The only workaround for now is to not use the Nimbus LaF when using
profiling features in the IDE.
Comment 10 Jiri Sedlacek 2008-08-26 15:49:45 UTC
Original problem on GTK LaF is workarounded in 6.5 Milestone 1, problem on Nimbus LaF is workarounded for 6.5.


changeset:   97859:26bdb73fae1c
date:        Tue Aug 26 16:48:21 2008 +0200
summary:     Bugfix #135812 Workaround for CCE from FilterComponent: hardcoded border on Nimbus
Comment 11 Quality Engineering 2008-09-01 17:30:28 UTC
Integrated into 'main-golden', available in build *200809011401* on http://bits.netbeans.org/dev/nightly/
Changeset: http://hg.netbeans.org/main/rev/26bdb73fae1c
User: Jiri Sedlacek <jis@netbeans.org>
Log: Bugfix #135812 Workaround for CCE from FilterComponent: hardcoded border on Nimbus
Comment 12 Jiri Sedlacek 2008-09-06 00:41:51 UTC
*** Issue 146368 has been marked as a duplicate of this issue. ***
Comment 13 Jindrich Sedek 2008-09-23 08:37:10 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo