Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 135732 - Shortcut Ctrl-U,U does not work properly
Shortcut Ctrl-U,U does not work properly
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Key bindings
6.x
All All
: P2 with 3 votes (vote)
: 6.x
Assigned To: issues@editor
issues@editor
61fixes3-fixed
:
: 130070 135375 137488 138205 143876 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 20:14 UTC by frankioski
Modified: 2008-09-04 13:23 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description frankioski 2008-05-23 20:14:23 UTC
Version: 6.1 FCS

Editor shortcut Ctrl-U,U (to make selected text uppercase) only works on the first go.  On next attempt, I found that I
would have to navigate to another editor window and back before trying again for it to work.  Otherwise, the keystrokes
do nothing at all.
Comment 1 frankioski 2008-05-23 20:25:47 UTC
In fact, any attempt to copy-and-paste results in strange behavior after Ctrl-U,U.  Apparently, copy (Ctrl-C) stops
working and pasting (Ctrl-V) only pastes what was previously copied into the buffer before Ctrl-U,U was invoked.
Frustrating.
Comment 2 mg11 2008-05-26 08:50:23 UTC
I have the same behavior in NetBeans IDE 6.1 (Build 200804211638) on Windows XP SP3. The function "Convert selection to
uppercase" (Ctrl-U, then U) was working properly in 6.0. Thank you for the feedback.
Comment 3 Jiri Prox 2008-05-26 10:54:16 UTC
Reproducible,

I agree it's very annoying -> P2

Product Version: NetBeans IDE Dev (Build 20080525200304)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Linux version 2.6.22-14-generic running on i386; UTF-8; en_US (nb)
Userdir: /home/jp159440/.netbeans/dev
Comment 4 Vitezslav Stejskal 2008-06-02 10:45:57 UTC
Ok, I can reproduce it too and it really screws up copy/paste operations. Thanks for the report.
Comment 5 Vitezslav Stejskal 2008-06-02 10:49:05 UTC
Ctrl-INSERT, Shift-INSERT seem to be unaffected by this.
Comment 6 Jiri Prox 2008-06-18 07:12:56 UTC
*** Issue 137488 has been marked as a duplicate of this issue. ***
Comment 7 Max Sauer 2008-06-18 09:25:43 UTC
*** Issue 130070 has been marked as a duplicate of this issue. ***
Comment 8 ats37 2008-06-18 12:28:03 UTC
Version: 6.1 FCS (plus patches from update centre), running under Sun's JDK 1.6.0_02 on Windows XP.

I too am seeing this (in various editors), but have found the subsequent attempts don't always "do nothing at all". 
Sometimes it just changes the first character of the new selection, sometimes none of them.  It's not just copy/paste
that's affected e.g. convert a selection to upper case (Ctrl-U u) then another selection (or even the same one) to lower
case (Ctrl-U l) or attempting to switch case (Ctrl-U s) is broken too.  Also, changing a selection to upper case then
selecting another block and starting to type doesn't replace the selection with what I'm typing like I expected, but
just inserts at the caret position and leaves the selection intact as well.
Lastly, I've found I can get it working again not just by "navigate to another editor window", but also by switching
(Alt-Tab) to any other app and back again prior to doing the next selection.
Comment 9 liujiaguang 2008-06-25 08:50:24 UTC
Yes, the bug occurred in my NetBeans IDE, v6.0, v6.0.1 and v6.1, both English version and Simplified Chinese version.
When editing a *.java or *.jsp file, if you select a text and then want to convert it to upper case or to lower case, 
the shortcut Ctrl+U,U or Ctrl+U,L can work successfully only at the first time in each opened file. And then, in the 
same editor(TopComponent) with the opened file, Ctrl+U,U or Ctrl+U,L will not work anymore :-(

And sometime shortcut copy-and-paste(Ctrl+C and Ctrl+V) can't work properly, I don't know whether it is a new bug or 
it is just a side-effect of Ctrl+U.

System Info: 
  Product Version         = NetBeans IDE 6.1 (Build 200805300101)
  Operating System        = Windows XP sp3 version 5.1.2600 running on x86
  Java; VM; Vendor        = 1.6.0_06; Java HotSpot(TM) Client VM 10.0-b22
  Java Home               = D:\jdk1.6.0_06\jre
  System Locale; Encoding = zh_CN (nb); GB18030
===============================================
Chinese:

是的,这个缺陷在我使用的NetBeans IDE上也存在,含v6.0、v6.0.1与v6.1这几个版本,无论是英文版还是简体中文版。
当编辑一个*.java或*.jsp文件时,如果你选择一段文本并想把它转换为大写或小写字母时,对于每一个打开的被编辑文件而言,只有第一次使用快捷键
Ctrl+U,U或Ctrl+U,L时,这个快捷键是可正确执行的。对于同一个文件的编辑器(窗口),快捷键Ctrl+U,U或Ctrl+U,L以后就不能在工作了(不再响应
快捷键指令):-(

有时候,复制-粘贴((Ctrl+C and Ctrl+V))快捷键也不能正常使用,我还不能确认这该算是一个新缺陷,还是应属于Ctrl+U缺陷的副作用。

产品版本: NetBeans IDE 6.1 (Build 200805300101)
Java: 1.6.0_06; Java HotSpot(TM) Client VM 10.0-b22
系统: Windows XP 版本 5.1 运行于 x86 上; GB18030; zh_CN (nb)
Comment 10 Jiri Prox 2008-06-25 11:59:48 UTC
*** Issue 138205 has been marked as a duplicate of this issue. ***
Comment 11 Vitezslav Stejskal 2008-06-25 16:06:09 UTC
http://hg.netbeans.org/main/rev/c0942efca806
Comment 12 Jiri Prox 2008-06-26 08:00:50 UTC
verified

Product Version: NetBeans IDE Dev (Build 20080626015438)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b12
System: Linux version 2.6.22-15-generic running on i386; UTF-8; en_US (nb)
Comment 13 Jiri Prox 2008-06-26 08:07:42 UTC
This should go to patch3
Comment 14 pslechta 2008-06-26 09:12:19 UTC
Changing status whiteboard to 61fixes3-candidate and target milestone to 6.5 M2 (6.1 is out already).
Comment 15 Quality Engineering 2008-06-27 16:26:04 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #285 build
Changeset: http://hg.netbeans.org/main/rev/c0942efca806
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #135732 (fixed): Caret.setSelectionVisible is not for unselecting selected text
Comment 16 Vitezslav Stejskal 2008-07-17 10:12:41 UTC
*** Issue 135375 has been marked as a duplicate of this issue. ***
Comment 17 rbalada 2008-07-18 14:18:47 UTC
I've transplanted the changeset http://hg.netbeans.org/main/rev/c0942efca806 into release61_fixes repository as
http://hg.netbeans.org/release61_fixes/rev/c493b38f21bc
Comment 18 Jiri Prox 2008-08-21 08:42:48 UTC
verified in patch
Comment 19 Vitezslav Stejskal 2008-08-21 15:08:50 UTC
*** Issue 143876 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo