Bug 135672 - Mercurial support doesn't scan project for changes
Mercurial support doesn't scan project for changes
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All Windows XP
: P2 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 10:39 UTC by Dan Kolar
Modified: 2008-10-20 08:02 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
patch for commit (3.99 KB, patch)
2008-05-26 16:05 UTC, Padraig Obriain
Details | Diff
updated patch (25.09 KB, patch)
2008-05-30 16:12 UTC, Padraig Obriain
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Kolar 2008-05-23 10:39:18 UTC
1) When some change is made in project, plugin see it only if accodring file/folder is opened in Project/File view. So
invoking Mercurial -> Commit list only files, which have been viewed.
2) Because plugin doesn't scan project for chnages, it does show even deleted files, and this can't be resolved even by
closing/opening the project, only by restart by IDE (and because no files are opened yet, we get the #1 case)
Comment 1 Padraig Obriain 2008-05-23 10:52:29 UTC
Please give a specific test case.

I am not sure I understand the description.
Comment 2 Padraig Obriain 2008-05-26 10:30:16 UTC
Are you referring to changes made outside the IDE?
Comment 3 Dan Kolar 2008-05-26 10:45:40 UTC
Yes, but IDE support for CVS/SVN scan project folders, when you use commit on project. Even if file is changed, or
deleted outside of IDE, CVS/SVN support changes commit list appropriately, but Mercurial support doesn't.
Comment 4 Padraig Obriain 2008-05-26 14:38:18 UTC
See http://www.netbeans.org/issues/show_bug.cgi?id=116104 for corresponding work for Subversion.
Comment 5 Padraig Obriain 2008-05-26 16:05:09 UTC
Created attachment 61929 [details]
patch for commit
Comment 6 John Rice 2008-05-27 14:33:34 UTC
This will have a significant performance impact when you go to do a commit against a repository with a large number of
changes made outside of the IDE, but there is nothing we can do about it.
Comment 7 Dan Kolar 2008-05-29 12:17:48 UTC
Well, IDE commit isn't even able to notice file was deleted from project using IDE, only after restart of IDE...
Comment 8 Padraig Obriain 2008-05-30 16:12:15 UTC
Created attachment 62177 [details]
updated patch
Comment 9 Tomas Stupka 2008-06-20 15:34:02 UTC
- applied the patch provided by padraig - 4a40bf7f5977 - should solve the originally reported problem with not recognized external changes.

> Well, IDE commit isn't even able to notice file was deleted from project using IDE, only after restart of IDE...
can't reproduce. could you please elaborate? if possible in a separate issue as this seems to be a different problem. thanks

the solution indeed has impact also on situation where a deep status refresh isn't needed. We should reconsider a easy way to switch it off - filed a new 
issue to cover it - #137826


Comment 10 pribyl 2008-10-20 08:02:03 UTC
Product Version: NetBeans IDE 6.5 RC1 (Build 200810171318)
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b15
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

Verified on 6.5 RC1 (the original issue)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo