Bug 135663 - Height of Toolbar grows
Height of Toolbar grows
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
:
: 117546 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 09:30 UTC by oldmangloom
Modified: 2009-02-19 22:53 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Toolbar with more Height than usual (5.94 KB, image/png)
2008-05-23 09:31 UTC, oldmangloom
Details
Error Messages in IDE Output window (32.65 KB, image/png)
2008-05-23 09:32 UTC, oldmangloom
Details
Screenshot of the PaintApp with a far too big Toolbar (27.14 KB, image/png)
2008-07-23 09:20 UTC, oldmangloom
Details

Note You need to log in before you can comment on or make changes to this bug.
Description oldmangloom 2008-05-23 09:30:41 UTC
I am using Ubuntu 8.04 with Java JDK 1.6 and NetBeans 6.1.
When I start my NetBeans RCP-App and just use it, the Height
of the Toolbar grows (see Screenshots).
I am not sure if this is really a NetBeans-Bug or a GTK-Bug.
Maybe the Error is related to my usage of Lookups, because
the Toolbar grows everytime I activate one of my TopComponents
by just clicking on it.
Comment 1 oldmangloom 2008-05-23 09:31:44 UTC
Created attachment 61808 [details]
Toolbar with more Height than usual
Comment 2 oldmangloom 2008-05-23 09:32:18 UTC
Created attachment 61809 [details]
Error Messages in IDE Output window
Comment 3 Petr Chytil 2008-07-22 13:55:10 UTC
Hi oldmangloom,

this seems very similar to issue # 117546. That issue occurred only on GNOME.
Comment 4 oldmangloom 2008-07-22 15:06:45 UTC
Hi pchytil,

I tested the PaintApp to reproduce the Error and now
it works, with the following Environment:

Product Version: NetBeans IDE 6.1 (Build 200804211638)
Java: 1.5.0_15; Java HotSpot(TM) Client VM 1.5.0_15-b04
System: Linux version 2.6.24-19-generic running on i386; UTF-8; de_DE (nb)
Userdir: /home/guido/.netbeans/6.1)
Ubuntu - Gnome, Metal-Look-and-Feel

Also my own App works now without that Bug. So I think is
an Issue with JDK 1.6 and Gnome (GTK).
Comment 5 oldmangloom 2008-07-23 09:18:21 UTC
UPDATE:

Installed sun-java6 again, and the error is back! The Error is the same as in
117546. You can open the PaintApp-Demo, create two Cancas and switch between
them, and your Toolbar will grow (see Screenshot). The Toolbar also grows, if
you resize the Window of the App.
Comment 6 oldmangloom 2008-07-23 09:20:12 UTC
Created attachment 65323 [details]
Screenshot of the PaintApp with a far too big Toolbar
Comment 7 Petr Chytil 2008-07-24 13:39:47 UTC
Thanks for testing oldmangloom,
I agree, that issue is reproducible, even with empty platform app project. Just open output window in the started
platform app and the toolbar grows a bit. This is reproducible on GNOME with JDK 6, as GTK is used as default L&F since
JDK 1.6.0 update 1.

So I'm closing issue # 117546 as duplicate of this issue, because this one is more general. The problem does not occur
only in PaintApp demo.
Comment 8 Petr Chytil 2008-07-24 13:41:55 UTC
*** Issue 117546 has been marked as a duplicate of this issue. ***
Comment 9 Stanislav Aubrecht 2008-11-28 11:42:33 UTC
reporter, please try reproducing this issue again (toolbars have been completely rewritten) and reopen if necessary

4f828389f2be


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo