Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 135661 - A project is debugged several times in one session
A project is debugged several times in one session
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Debugger
6.x
All All
: P2 (vote)
: TBD
Assigned To: Alexey Butenko
issues@javafx
FXPLUGIN_PREVIEW_WAVED
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 09:15 UTC by Alexandr Scherbatiy
Modified: 2008-08-21 11:46 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2008-05-23 09:15:39 UTC
Steps to reproduce:

- Create a JavaFX project
- Create a JavaFX main file:
--------------------------------------
var a = 10;
var b = 20;
var c = a + b;
var d = a - b;
--------------------------------------
- Add Breakpoints for each line
- Press Debug Main Project button
- Press Continue (F5) button 
  The debugger jumps to the first line after the last one ( from 6 to 3) instead of ending the Application. 

Listening on 2260
User program running
LineBreakpoint Main.fx : 6 successfully submitted.
LineBreakpoint Main.fx : 5 successfully submitted.
LineBreakpoint Main.fx : 4 successfully submitted.
LineBreakpoint Main.fx : 3 successfully submitted.
Breakpoint hit at line 6 in class javafxapplication1.Main by thread main.
Thread main stopped at Main.fx:6.
User program running
Breakpoint hit at line 6 in class javafxapplication1.Main by thread main.
Thread main stopped at Main.fx:6.
User program running
Breakpoint hit at line 3 in class javafxapplication1.Main by thread AWT-EventQueue-0.
Thread AWT-EventQueue-0 stopped at Main.fx:3.
User program running
Breakpoint hit at line 4 in class javafxapplication1.Main by thread AWT-EventQueue-0.
Thread AWT-EventQueue-0 stopped at Main.fx:4.
User program running
Breakpoint hit at line 5 in class javafxapplication1.Main by thread AWT-EventQueue-0.
Thread AWT-EventQueue-0 stopped at Main.fx:5.
User program running
Breakpoint hit at line 6 in class javafxapplication1.Main by thread AWT-EventQueue-0.
Thread AWT-EventQueue-0 stopped at Main.fx:6.
User program running
Breakpoint hit at line 3 in class javafxapplication1.Main by thread AWT-EventQueue-0.
Thread AWT-EventQueue-0 stopped at Main.fx:3.
Comment 1 Alexei Mokeev 2008-07-09 14:31:16 UTC
In progress. Awaiting for detailed evaluation from Alexey. 
Comment 2 Alexey Butenko 2008-07-09 16:07:41 UTC
mark as fixed, please verify
Comment 3 Alexandr Scherbatiy 2008-07-10 14:11:15 UTC
The issue is reproduced if starts the Debugger by <F7> key. In this case 2 debuggers start.
Comment 4 Alexandr Scherbatiy 2008-07-10 14:13:32 UTC
It is reproduced with following steps:

- Create a JavaFX project
- Create a JavaFX main file:
--------------------------------------
var a = 10;
var b = 20;
var c = a + b;
var d = a - b;
--------------------------------------
- Add Breakpoints for each line
- Press Debug Main Project button
- Press <F7>  key several times 
   The debugger jumps to the first line after the last one 
Comment 5 Alexey Butenko 2008-07-10 15:02:33 UTC
By <F7> 2 instances of the debugger started, investigating the reason
Comment 6 Andrey Yamkovoy 2008-07-15 19:38:52 UTC
The reason of this problem on compiler side.
The following JIRA issue was created: http://openjfx.java.sun.com/jira/browse/JFXC-1582
Comment 7 Alexey Butenko 2008-08-13 10:34:27 UTC
I've disabled F7 to avoid starting 2 Debugger instances: Java and JavaFX.
Comment 8 Alexandr Scherbatiy 2008-08-21 11:46:26 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo