Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 135586 - Regression: Re-enable Populate Catalog and make sure the build system understands it
Regression: Re-enable Populate Catalog and make sure the build system underst...
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL Project
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Kirill Sorokin
issues@soa
affects-docs, 61fixes2-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 11:04 UTC by Kirill Sorokin
Modified: 2008-07-10 15:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kirill Sorokin 2008-05-22 11:04:35 UTC
Since the default retriever behavior is to store the downloaded files to nbproject/private/cache/retriever, they will
never be committed to a VCS. Thus if someone checks them out and tries to build without having an internet connection,
the build will fail, as external resources are not cached.

We need to re-introduce the project's Populate Catalog action which existed previously and make sure the files it
generates are:
1) properly stored in a folder accessible by version control
2) properly referenced from the project-wide xml catalog
Comment 1 Kirill Sorokin 2008-05-22 11:09:56 UTC
Fixed. Changeset: http://hg.netbeans.org/main/rev/05b33bc911f9
Comment 2 pslechta 2008-05-28 14:05:35 UTC
QA, please verify this fix till 09-Jun-2008, so it can be part of NB 6.1 patch 2.
Comment 3 Kirill Sorokin 2008-05-29 10:23:08 UTC
An add-on fix take takes into account schema includes (previously only imports were handled):
http://hg.netbeans.org/main/rev/87f1917224bc
Comment 4 Andrei Chistiakov 2008-05-30 17:31:23 UTC
Verified with build 20080530121740.
Comment 5 pslechta 2008-06-02 12:44:22 UTC
The fix has been ported into the release61_fixes repository.

http://hg.netbeans.org/release61_fixes/rev/ea185e08bff1
http://hg.netbeans.org/release61_fixes/rev/41150eae7874


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo