Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 135481 - Calculate dependencies correctly for implementation dependencies [was:The module org.netbeans.modules.xml.schema.completion cannot be updated.]
Calculate dependencies correctly for implementation dependencies [was:The mod...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
:
: 138877 138891 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 11:03 UTC by pgebauer
Modified: 2008-07-30 10:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
catalog.xml (4.16 MB, text/xml)
2008-05-21 11:08 UTC, pgebauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pgebauer 2008-05-21 11:03:43 UTC
If you try to use catalog.xml for update of org.netbeans.modules.xml.schema.completion (via Editing Files), you will get
IMHO pointless request for "XML Retriever" module. The content of module "XML Retriever" wasn't changed and it is
included in the catalog.xml.
Comment 1 pgebauer 2008-05-21 11:08:35 UTC
Created attachment 61668 [details]
catalog.xml
Comment 2 pgebauer 2008-05-23 08:51:35 UTC
It seems there is the sole dependency on implementation version between xml.schema.completion and xml.retriever so
increment spec. version of xml.retriever without any changes in dependency should fix the issue.
Comment 3 Lukas Hasik 2008-05-27 08:26:46 UTC
I'm increasing priority and changing summary.

This issue is caused by incorrect treatment of implementation dependencies in plugin manager. This has to be fixed. 

It can be reproduced with 61 patch 1. The IDE Platform module doesn't install together with other updates because of the
"Plugin IDE Platform[org.netbeans.modules.ide.kit/1.3.1] cannot be installed, some dependencies can be satisfied:
[module org.netbeans.modules.xml.retriever/1 = 200804211638]". The module can be correctly installed when after other
plugins are installed in IDE i.e. after IDE restart. This is inconvenient as it requires to use the plugin manager two
times. It is also confusing for the user. And users can easily miss the "forgotten plugin update"
Comment 4 Jiri Rechtacek 2008-05-27 12:20:32 UTC
Yes, I agree it's either bug in AU Services, or something wrong in Update Descriptor perhaps. I'm evaluating it...
Comment 5 Jiri Rechtacek 2008-05-28 12:01:32 UTC
http://hg.netbeans.org/core-main/rev/aba056748966
Comment 6 Lukas Hasik 2008-05-28 14:16:59 UTC
the issue for 61 user installing patch1 happens only when they click the update bubble. When they use Tools > Plugins
then all new updates (including IDE Platform) are installed
Comment 7 Quality Engineering 2008-06-03 04:16:20 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #234 build
Changeset: http://hg.netbeans.org/main/rev/aba056748966
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #135481: Calculate dependencies correctly for implementation dependencies [was:The module org.netbeans.modules.xml.schema.completion cannot be updated.]
Comment 8 Jiri Rechtacek 2008-07-15 12:33:04 UTC
*** Issue 138877 has been marked as a duplicate of this issue. ***
Comment 9 Jiri Rechtacek 2008-07-30 10:35:23 UTC
*** Issue 138891 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo