Bug 135410 - javax.swing.text.BadLocationException: Invalid offset=28476 not within <0, 11481>
javax.swing.text.BadLocationException: Invalid offset=28476 not within <0, 11...
Status: RESOLVED FIXED
Product: javascript
Classification: Unclassified
Component: Editor
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Torbjorn Norbye
issues@javascript
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 11:24 UTC by hat27533
Modified: 2009-02-27 14:26 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.35 KB, text/plain)
2008-05-20 11:24 UTC, hat27533
Details
stacktrace (3.43 KB, text/plain)
2008-06-11 11:54 UTC, attiliodona
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hat27533 2008-05-20 11:24:10 UTC
Build: NetBeans IDE 6.1 (Build 200804211638)
VM: Java HotSpot(TM) Client VM, 1.5.0_14-b03, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_14-b03
OS: Windows XP, 5.1, x86

User Comments: 
editing a js file
Comment 1 hat27533 2008-05-20 11:24:20 UTC
Created attachment 61608 [details]
stacktrace
Comment 2 attiliodona 2008-06-11 11:54:46 UTC
Created attachment 62655 [details]
stacktrace
Comment 3 Exceptions Reporter 2008-07-24 07:59:00 UTC
This issue has already 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=38313
Comment 4 martin_adamek 2008-07-30 22:38:54 UTC
I wasn't able to reprosuce in any way, tried blind fix.
http://hg.netbeans.org/main/rev/9bc8c9087b43
Comment 5 Quality Engineering 2008-07-31 04:10:52 UTC
Integrated into 'main-golden', available in build *200807310201* on http://bits.netbeans.org/dev/nightly/
Changeset: http://hg.netbeans.org/main/rev/9bc8c9087b43
User: Martin Adamek <martin_adamek@netbeans.org>
Log: Blind fix for #135410: javax.swing.text.BadLocationException: Invalid offset=28476 not within <0, 11481>
Comment 6 Exceptions Reporter 2008-10-16 19:50:31 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200810160201)
http://statistics.netbeans.org/exceptions/detail.do?id=129123
Comment 7 martin_adamek 2008-10-16 22:11:37 UTC
Well, exception_reporter seems to be confused - the stack trace is different.
Comment 8 martin_adamek 2008-10-16 22:21:06 UTC
... and seems to be introduced by Tor's fix of issue 146936
Tor, could you please have a look?
Comment 9 Torbjorn Norbye 2008-10-17 02:06:15 UTC
This is incorrectly reopened by the exceptions reporter; the new stacktrace is not equivalent to the old one, and this
is a completely different issue than the original one.
Comment 10 Torbjorn Norbye 2008-10-17 02:16:01 UTC
I have filed a separate issue to track the new exception: issue 150471 . I will close this issue again as truly fixed -
since it's a P1 I don't want to leave it open even though it may reopened again if any more exceptions come in.

The issue with the exception reporter incorrectly reopening separate issues is tracked in issue 150349.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo