Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 135311 - Mercurial Username can't be modified.
Mercurial Username can't be modified.
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
61fixes2-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 13:39 UTC by Peter Pis
Modified: 2008-07-10 15:05 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Pis 2008-05-19 13:39:38 UTC
Product Version         = NetBeans IDE 6.1 (Build 200804211638)
Operating System        = Windows XP version 5.1 running on x86
Java; VM; Vendor        = 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11; Sun Microsystems Inc.
Runtime                 = Java(TM) SE Runtime Environment 1.6.0_10-beta-b13
Java Home               = d:\Java\jdk1.6.0_10\jre

Steps:
1. "Tools | Options | Miscellaneous | Versioning | Mercurial | Mercurial User Name" -> enter new valid name and confirm
by "OK" button.
2. Invoke "Mercurial" options again.

The pristine user name is shown. The new one is not remembered. 

One of the possible solutions would be to remove this property from within the Mercurial's options tab. There is still
"Mercurial | Properties" action which handles it well.
Comment 1 Padraig Obriain 2008-05-19 14:23:36 UTC
I think that this may be a Windows specific issue.

It works for me on Solaris where it changes the the username in ~/.hgrc.
Comment 2 John Rice 2008-05-19 14:24:58 UTC
Not seeing this on nevada. Will try and reproduce on Win XP.
Comment 3 John Rice 2008-05-19 14:27:02 UTC
Should see the entry added to %USERPROFILE%\Mercurial.ini on Win XP
Comment 4 Peter Pis 2008-05-19 15:02:21 UTC
Yes, the entry (and "Mercurial.ini") is created correctly, but whenever the "Options" are invoked still the same user
name is  shown.
Comment 5 John Rice 2008-05-20 11:30:19 UTC
Peter on Windows XP I cannot reproduce this issue.

Can you give me a reprioducible test case? You need to tell me how username is set in the following locations before you
start and the exact steps to repo it - thanks.

c:\Mercurial\Mercurial.ini
c:\Documents and Settings\<user>\Mercurial.ini

I deleted username from both locations above and saw the default generated name in the Options. This is not persisted to
the above ini files. To get it to appear you can always delete what's in the users Mercurial.ini and make sure there is
no username entry in the install location.

John@your-bf74efdc96

I then changed to john@foobar.com and clicked OK.
When I bring Options back up this is still what I see and the info has been placed in:
c:\Documents and Settings\<user>\Mercurial.ini
[ui]
editor = notepad
username = john@foobar.com

If having this entry I then change it again to say john@foobar2.com, it still does what I'd expect and appears when I
bring up Options again.
Comment 6 Peter Pis 2008-05-20 12:13:12 UTC
Sorry, today I am not able to reproduce it either. Strange. Could it happen that some process held the lock on it? Closing.
Comment 7 Peter Pis 2008-05-20 16:02:32 UTC
Verifying issue #126803 in 6.1 and patch1 I've run into this problem and steps provided here are reproducible.

Product Version: NetBeans IDE 6.1 (Build 200804211638)

Could you please look at it?
Comment 8 Peter Pis 2008-05-20 16:11:07 UTC
The Patch1 should contain the fix this (NB 61). For latest trunk build I am not able to reproduce it. 
Comment 9 Padraig Obriain 2008-05-21 08:24:16 UTC
Where are the sources I should be looking at?

Is it http://hg.netbeans.org/release61_fixes/file/tip?
Comment 10 Peter Pis 2008-05-21 08:35:25 UTC
It should be there.
Comment 11 Padraig Obriain 2008-05-21 08:47:18 UTC
It looks like the second last patch in #126803 is not in release61_fixes.

Comment 12 Padraig Obriain 2008-05-21 09:24:16 UTC
The bug is p[resent in 6.1 but not in latest trunk build.
Comment 13 Padraig Obriain 2008-05-21 10:26:50 UTC
Revision 154979465edd in trunk is not in release61_fixes.
Comment 14 Peter Pis 2008-05-22 08:35:14 UTC
Fixed in trunk.
Comment 15 Peter Pis 2008-05-22 08:35:43 UTC
Verified in trunk.
Comment 16 rbalada 2008-05-29 11:24:12 UTC
I've backported the changeset http://hg.netbeans.org/main/rev/154979465edd from main repository into release61_fixes
repository as http://hg.netbeans.org/release61_fixes/rev/cf0b5c3a63f5

changeset:   77599:cf0b5c3a63f5
tag:         tip
user:        padraigob@netbeans.org
date:        Tue Apr 01 10:45:24 2008 +0100
summary:     126803: Username settings - part4 Windows GC race issue
Comment 17 Peter Pis 2008-06-19 10:54:09 UTC
Verified with patch2.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo