Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 135301 - Indexing consuming all resources
Indexing consuming all resources
Status: RESOLVED DUPLICATE of bug 133943
Product: java
Classification: Unclassified
Component: Source
6.x
PC Windows ME/2000
: P3 with 1 vote (vote)
: TBD
Assigned To: Pavel Flaska
issues@java
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 10:35 UTC by michael
Modified: 2008-07-31 09:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description michael 2008-05-19 10:35:56 UTC
Indexing is consuming all resources. 

The ide is virtually unusable during indexing.

Indexing a large project takes in excess of 10 to 15 minutes.

There is no way of defining indexing excludes within the project directory.

Indexing is repeated for the entire project on each ide restart.
Comment 1 grafity 2008-06-03 17:46:50 UTC
in a project with more than 7000 files takes more than 3 hours to index
Comment 2 Jan Lahoda 2008-06-09 12:00:24 UTC
I would like to separate a few different case:
-indexing/compiling when the project is opened for the first time (or after bigger changes in that project, e.g. change
of classpath): currently, the only thing that can be done, IMO, is to look for bottlenecks and improve the performance
bit by bit.
-reindexing on start-up: there should be a time-stamp check (which is quite fast), and if nothing changed, nothing
should be indexed/compiled. If the project is recompiled on each startup, we need to find out the cause and fix it.
-the excludes can be defined, at least for J2SE projects (Project Properties/Sources/"Includes/Excludes") and Freeform
projects

Passing to performance team.
Comment 3 Jan Becicka 2008-07-31 09:21:39 UTC

*** This issue has been marked as a duplicate of 133943 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo