Bug 134767 - Imcompatible Xalan Version
Imcompatible Xalan Version
Status: NEW
Product: third-party
Classification: Unclassified
Component: -- Other --
6.x
Macintosh Mac OS X
: P1 (vote)
: TBD
Assigned To: issues@third-party
issues@third-party
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-09 11:22 UTC by gilcorreira
Modified: 2008-08-07 14:17 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (84.06 KB, text/plain)
2008-05-10 17:19 UTC, rweaver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gilcorreira 2008-05-09 11:22:23 UTC
Hi,

I have a big problem on my Netbeans 6.1, i'm work on MacOs and after install the IReport plugin, my netbeans is broken!!!!
When initialize the IDE it's show the next message:

"An imcompatible Xalan version has been detected on the IDE's Classpath. The IDE cannot start".

Somebody can help me?

Thanks.

Best Regards

Gil Correia
Comment 1 Marian Mirilovic 2008-05-09 12:34:29 UTC
gilcorreira, 
could you please attach message.log file located in 
${netbeans.userdir}/var/log/messages.log 
(see http://qa.netbeans.org/bugzilla/reportbug.html)
as attachment to this issue ? 

Thanks in advance.
Comment 2 rweaver 2008-05-10 17:12:37 UTC
I have the same error after installing some plugins. 

Looks like it might be due to the jmeter plugin, which includes a xalan.jar in the modules/jmeter/lib directory.

find . -name xalan* -print
./libs/xalan.jar
./modules/ext/xalan-2.7.0,jar.old
./modules/ext/xalan.jar
./modules/jmeter/lib/xalan.jar


Comment 3 rweaver 2008-05-10 17:19:46 UTC
Created attachment 61209 [details]
messages.log
Comment 4 rweaver 2008-05-10 17:21:45 UTC
BTW, you might want to add to your FAQ about uploading files from the .netbeans directory, as the browser on Mac doesn't let you get to hidden directories, 
so you have to cp the file somewhere you can browse in order to upload.
Comment 5 Jesse Glick 2008-05-12 22:18:06 UTC
So uninstall the JMeter plugin and file a bug for its author. It is not supported on this website.
Comment 6 rweaver 2008-05-12 23:06:18 UTC
So I think I agree with the original poster that this is a bug in that NetBeans flat won't start after the plugin is 
installed (iReport). Didn't happen to me on Winbloze, so I'm thinking that this is a problem only on OS X.

The issue is that after you use the plugins to install this, you can't even start NB. The dialog you get gives you a 
link to an FAQ that doesn't help (tells you to delete the Xalan jar file from the JRE lib, which doesn't exist).

In my case there were several xalan.jar files in the modules directories, but no indication of which would need to be 
deleted (I tried renaming them as shown in the find from my original post).

The FAQ should be updated with how to disable the module that is causing the issue. I was only able to get it to start 
up after deleting my .netbeans/6.1 subdirectory (which obviously reset everything back to default settings).
Comment 7 rweaver 2008-05-12 23:14:57 UTC
I did a quick test and by renaming all of the xalan*.jar files in the .netbeans/6.1 subdirectories except the one in 
lib, I can get NB 6.1 to load without the error. Didn't try the iReport or JMeter modules to see if they work OK with 
the version of xalan.jar that is in the .netbeans/6.1/lib directory:

find . -name xal* -print
./6.1/libs/xalan.jar
./6.1/modules/ext/xalan-2.7.0.jar.save
./6.1/modules/ext/xalan.jar.save
./6.1/modules/jmeter/lib/xalan.jar.save
Comment 8 rich32 2008-05-15 09:31:26 UTC
Hi,

got this problem too : netbeans 5.5.1 and then netbeans 6.1 on Solaris 10 with jdk1.5.0_10.
- the FAQ that appears on the popup is no help.

Removing the appropriate xalan.jar allows the netbeans to start but then creating a new project fails (at 25%).

Sounds likes this issue has been going on for a number of versions - and it's a show stopper - what's going on?
rich.
Comment 9 clrod 2008-06-30 05:18:47 UTC
i have the same problem that my ide doesn't start because of the xalan problen in mac os X ,do someone can tell me where exactly are the files that i have to 
deleted for netbeans to work?, ad start again beacuse everytime i erased does not work. 
Comment 10 janicki 2008-08-07 04:52:44 UTC
I removed the following file (from the iReports plugin) and I was able to start NetBeans again.  And iReports still seems to work, although I haven't tested very 
much.  (I installed iReports right before this problem showed up.)

~/.netbeans/6.1/modules/ext/xalan.jar
Comment 11 janicki 2008-08-07 04:59:37 UTC
Also, note that "~/.netbeans/6.1/libs/xalan.jar" still exists, so I assume that's where the necessary Xalan-related classes are being found now.

Lastly, to "rweaver": Renaming files may fool the NetBeans startup checker, but the checker is trying to avoid that older xalan library for a reason... circumventing the check could cause trouble later?
Comment 12 rweaver 2008-08-07 14:17:33 UTC
You missed the point on my rename. I renamed them with a .save suffix, so that NetBeans wouldn't load them. 

My suggestion is that NB should warn you about the problem in a way that is easier to fix than digging through all the
jar files.

Ideally it could catch this problem as part of the process of installing the plugin: meaning when NB installs the
plugin, have it check the files being installed to see if any of them would cause a problem like this, thereby avoiding
the problem of ending up with an unstartable NB.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo