Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 134684 - Installer file is reported as broken with BLOCK_SIZE set to 1K
Installer file is reported as broken with BLOCK_SIZE set to 1K
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: NBI
6.x
All Linux
: P3 (vote)
: 6.x
Assigned To: dlipin
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 15:52 UTC by sreque
Modified: 2008-05-14 16:07 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
output of command ./netbeans-6.1-linux.sh --verbose --output out.txt (14.06 KB, text/plain)
2008-05-09 23:00 UTC, sreque
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sreque 2008-05-07 15:52:30 UTC
I cannot install netbeans 6.1 completed on my 32-bit Ubuntu 8.04 machine. I have downloaded the complete installer 3
times. The third time, I verified that the md5sum for the download was correct. Each time I get the following error: 

./netbeans-6.1-linux.sh 
Configuring the installer...
Searching for JVM on the system...
Extracting installation data...
Installer file /tmp/netbeans-6.1-linux.sh seems to be corrupted


Java -version outputs the following:
Java(TM) SE Runtime Environment (build 1.6.0_04-b12)
Java HotSpot(TM) Server VM (build 10.0-b19, mixed mode)
Comment 1 dlipin 2008-05-09 13:50:36 UTC
could you please run it in verbose mode:
./netbeans-6.1-linux.sh --verbose --output out.txt
and attach out.txt here?

thanks,
Dmitry
Comment 2 sreque 2008-05-09 23:00:22 UTC
Created attachment 61200 [details]
output of command ./netbeans-6.1-linux.sh --verbose --output out.txt
Comment 3 sreque 2008-05-09 23:04:09 UTC
I've attached the output of running the install script as you requested.
Comment 4 dlipin 2008-05-10 11:44:07 UTC
Hi,

It looks like the size of the file was reported in kilobytes instead of bytes.

Could you please also attach the output of the following commands:
$ ls -l ./netbeans-6.1-linux.sh
$ ls -l ./netbeans-6.1-linux.sh | awk ' { print $5 }' 2>/dev/null
$ man ls
$ ls --help
$ env

what is your shell? bash? csh ?
do you know by chance how to make ls on your system show size in bytes?


thanks,
Dmitry
Comment 5 sreque 2008-05-12 16:48:32 UTC
Haha, that fixed it! I purposely set my env variable BLOCK_SIZE=1K because I think it makes output from commands like ls
more readable, but setting it back to 1 and running the installer worked. The installer shouldn't make an such an
assumption about block sizes since they are configurable, but at least there is a work around for it. 
Comment 6 dlipin 2008-05-13 07:52:15 UTC
Oh.. I haven`t known of that feature before :)

I`ve founded a more decriptive topic on that...
http://www.gnu.org/software/coreutils/manual/html_node/Block-size.html

In fact, NetBeans Installer does not do anything about those special env variables: it just executes "ls -l".
I`ll check what I can do here to avoid such a situation in the future.

sreque, thanks for you investigations!
Comment 7 dlipin 2008-05-13 11:18:05 UTC
Fixed in development builds.
http://hg.netbeans.org/main/rev/3cc68f5cfbf8
Comment 8 Quality Engineering 2008-05-14 16:07:18 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #195 build
Changeset: http://hg.netbeans.org/main/rev/3cc68f5cfbf8
User: Dmitry Lipin <dlipin@netbeans.org>
Log: Issue #134684 Installer file is reported as broken with BLOCK_SIZE set to 1K


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo