Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 134605 - The NetBeans should be able to be installed after SS installation/removal.
The NetBeans should be able to be installed after SS installation/removal.
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: SUN Studio
6.x
All All
: P3 (vote)
: TBD
Assigned To: akumta
issues@installer
ssx1108
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 14:05 UTC by mesnik
Modified: 2008-10-08 16:14 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
SunStudio uninstall with Netbeans installed. (505.38 KB, text/plain)
2008-10-01 18:02 UTC, akumta
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mesnik 2008-05-06 14:05:50 UTC
Now NBI reports about error that some SunStudio specific classes could not be loaded from .nbi directory.
Comment 1 dlipin 2008-05-16 10:39:35 UTC
Hi Leonid,

I hope that the following fix will help to solve this problem
http://hg.netbeans.org/main/rev/795473d298a3

Please try the next NetBeans IDE installer build (starting with 200805170000) with SS installed: if it still complains 
about missing classes and installation is still not possible please let me know (with the log, certainly), I`ll 
continue working on it.

Please don`t be surprised to see those NCDFE errors in the log file - it is expected and mostly by design.

Please also create the fresh SS installers with this fix and try to 
1) Install SS
2) Install NetBeans 
3) Uninstall SS
3) Uninstall NetBeans
and 
1) Install NetBeans
2) Install SS 
3) Uninstall NetBeans
4) Uninstall SS

Please let me know if both scenarios goes smooth or there are any visible errors.
Comment 2 mesnik 2008-09-25 17:34:21 UTC
This issue should be verified. 
Comment 3 mesnik 2008-09-30 10:17:17 UTC
It was fixed in NBI and should be verified.
Comment 4 akumta 2008-10-01 17:48:15 UTC
If Netbeans(tried with installing  latest Netbeans 6.5 200809300201 bits)is installed, then SunStudio cannot be installed.
This is the error message:
It seems that the installation of IDE is corrupted.
The validation procedure issued the following warning:

The installation directory /opt/netbeans-6.1ss is missing.
Most likelt it was deleted manually.
Would you like to mark this product as not installed and continue?
If you click No the installer will exit.

Note that these products that depend on the IDE will also be disabled:

If one tries to procceed  with installation all products, except IDE are shown as 'Already installed'


Comment 5 akumta 2008-10-01 18:01:11 UTC
For this scenario:

Install Sun Studio.
Install Netbeans.
Uninstall Sun Studio.

Uninstaller dies with exception.
It partly removes Netbeans installation.
See attached log file




Comment 6 akumta 2008-10-01 18:02:27 UTC
Created attachment 70986 [details]
SunStudio uninstall with Netbeans installed.
Comment 7 dlipin 2008-10-06 13:48:51 UTC
BTW, to work with NetBeans components from SS installer you should have NetBeans IDE Installer engine classes in SS-
Installer engine. In particular - NbClusterConfigurationLogic, NetBeansUtils and, probably, NbWelcomePanel.
Unfortunately those classes are not bundled in the NB components configuration logic jar files.
Comment 8 mesnik 2008-10-08 16:14:04 UTC
The registry.xml becomes inconsistent by some reasons. The nb-base is removed and installer reports that nb-cnd does not
have required component nb-cnd. Installer blocks installation. 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo