Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 134576 - Editor window should be splitable to make work with large files easier
Editor window should be splitable to make work with large files easier
Status: VERIFIED DUPLICATE of bug 126575
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: TBD
Assigned To: David Simonek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 10:10 UTC by Petr Dvorak
Modified: 2009-03-26 16:07 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Dvorak 2008-05-06 10:10:10 UTC
I had a request for this feature from a NB user:

"...having multiple split-views of one large file would be nice to have..."

I know that I can now clone the document, undock the tab and dock it to the bottom of the document area so that I have
two splits of the same file. However, it would be nice to allow splitting the editor tab, so that the split is
associated only with a single tab.

Ideal situation:
1. You have 2 files opened: file1.java and file2.java.
2. You invoke "Split" from the popup menu of the tab for file2.java
-> you have the exactly the same appearance of the editor as you would have after "clone-undock-dock" sequence of file2.java

3. You switch to file1.java tab
-> you have only one view, there is no split
Comment 1 Petr Dvorak 2008-05-18 00:39:03 UTC
I have found a duplicate issue (#126575).

*** This issue has been marked as a duplicate of 126575 ***
Comment 2 Petr Dvorak 2009-03-26 16:07:05 UTC
Verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo