Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 134572 - IllegalArgumentException: URI scheme is not "file"
IllegalArgumentException: URI scheme is not "file"
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Libraries
6.x
All All
: P2 with 1 vote (vote)
: 6.x
Assigned To: David Konecny
issues@projects
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 61fixes2-fixed
:
: 142730 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 09:52 UTC by hazam
Modified: 2008-09-07 22:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.85 KB, text/plain)
2008-05-06 09:52 UTC, hazam
Details
stacktrace (2.12 KB, text/plain)
2008-05-08 14:25 UTC, phantumas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hazam 2008-05-06 09:52:03 UTC
Build: NetBeans IDE 6.1 (Build 200804211638)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05, Java(TM) SE Runtime Environment, 1.6.0_03-b05
OS: Linux, 2.6.22-14-generic, i386

User Comments: 
I was opening a Netbeans 6.0 Project with 6.1.
Comment 1 hazam 2008-05-06 09:52:08 UTC
Created attachment 61073 [details]
stacktrace
Comment 2 phantumas 2008-05-08 14:25:09 UTC
Build: NetBeans IDE 6.1 (Build 200804211638)
VM: Java HotSpot(TM) Client VM, 1.6.0_02-b06, Java(TM) SE Runtime Environment, 1.6.0_02-b06
OS: Windows XP, 5.1, x86

User Comments: 
I try to open a project which was build with Netbeans 6.01
Comment 3 phantumas 2008-05-08 14:25:13 UTC
Created attachment 61169 [details]
stacktrace
Comment 4 adilatilgan 2008-05-14 10:17:40 UTC
Product Version: NetBeans IDE 6.1 (Build 200804211638)
Java: 1.6.0_01; Java HotSpot(TM) Client VM 1.6.0_01-b06
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Userdir: C:\Documents and Settings\aatilgan\.netbeans\6.1



Cannot use 6.1 

Comment 5 David Konecny 2008-05-15 00:38:53 UTC
There is a nbfs: url which cannot be resolved after upgrade to NB6.1.
Comment 6 David Konecny 2008-06-04 02:16:55 UTC
Fixed: 2ca298cc2517
Comment 7 Quality Engineering 2008-06-04 15:51:24 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #237 build
Changeset: http://hg.netbeans.org/main/rev/2ca298cc2517
User: David Konecny <dkonecny@netbeans.org>
Log: #134572 - ignore absolute URIs to prevent URI schema exception
Comment 8 pgebauer 2008-06-10 13:55:19 UTC
This issue has been nominated for NB IDE 6.1 patch2 although it hasn't been verified by QE yet. If it isn't verified by
12-Jun-08, it's nomination will be removed.
Comment 9 David Konecny 2008-06-10 21:57:28 UTC
To reproduce try this:
* in NB 6.1 create Java project without Libraries Folder and add e.g. Struts library to classpath
* shutdown IDE and remove one of the Struts library jars (should be in enterprise5/modules/ext/struts folder)
* start the IDE again and you should get IllegalArgumentException
Comment 10 Jaromir Uhrik 2008-06-11 12:26:55 UTC
Verified in the following build where the reference problem is detected correctly instead of exception:

Product Version: NetBeans IDE Dev (Build 200806110005)
Java: 1.5.0_13; Java HotSpot(TM) Client VM 1.5.0_13-119
System: Mac OS X version 10.5.2 running on i386; MacRoman; en_US (nb)
Comment 11 pgebauer 2008-06-12 19:01:53 UTC
The fix has been ported into the release61_fixes branch:

http://hg.netbeans.org/release61_fixes/d80419b5adba
Comment 12 Jaromir Uhrik 2008-07-01 08:00:24 UTC
Verified in the patch2
Comment 13 David Konecny 2008-09-07 22:09:53 UTC
*** Issue 142730 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo