Bug 134428 - Deadlock: java.debug.SourceForBinaryQueryImpl vs. ProjectManager.mutex
Deadlock: java.debug.SourceForBinaryQueryImpl vs. ProjectManager.mutex
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jan Lahoda
issues@java
: RANDOM, THREAD
: 138258 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 19:48 UTC by Jesse Glick
Modified: 2008-07-08 04:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (19.29 KB, text/plain)
2008-05-02 19:50 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2008-05-02 19:48:03 UTC
I had just added a dep to an NBM project and the IDE froze. Probably random; had previously added many such deps without
problems. Was not using debugger.
Comment 1 Jesse Glick 2008-05-02 19:49:00 UTC
JDK 6, Ubuntu, NB from simpletests branch based on #e6b4de9702f6.
Comment 2 Jesse Glick 2008-05-02 19:50:05 UTC
Created attachment 60985 [details]
Thread dump
Comment 3 Martin Entlicher 2008-06-21 18:26:56 UTC
There is nothing from debugger. It's just org.netbeans.modules.java.debug package.
Comment 4 rmichalsky 2008-06-30 13:33:17 UTC
*** Issue 138258 has been marked as a duplicate of this issue. ***
Comment 5 Jesse Glick 2008-06-30 17:00:38 UTC
Increasing priority due to the fact that it happened to me numerous times the other day (see duplicate).
Comment 6 Jan Lahoda 2008-07-07 20:34:28 UTC
http://hg.netbeans.org/main/rev/f2d5b88a7f1c
Comment 7 Quality Engineering 2008-07-08 04:39:38 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #306 build
Changeset: http://hg.netbeans.org/main/rev/f2d5b88a7f1c
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #134428: preventing deadlock (acquire project read access before locking the private lock).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo