Bug 134307 - Provide support for Sakila sample database
Provide support for Sakila sample database
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 6.x
Assigned To: David Vancouvering
issues@db
http://wiki.netbeans.org/SakilaSuppor...
: PLAN
: 129828 136541 (view as bug list)
Depends on: 136541 138768 143250 143505
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 01:20 UTC by David Vancouvering
Modified: 2008-09-16 10:34 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Vancouvering 2008-05-01 01:20:56 UTC
Implement a solution that allows a user to easily install the Sakila sample database.  The challenge is the SQL file is
so large (2 MB) that it can't be loaded by our SQL Editor to be run like our other samples.  It also needs to be tweaked
with 'delimiter' blocks so that the stored procedures and triggers it creates can be correctly loaded.

The size is of some concern, as it impacts download size for NetBeans.  One possible solution is to build this as a
plugin that users can download, but which is not part of the standard install.
Comment 1 David Vancouvering 2008-06-05 16:46:44 UTC
Need to fix it so Sakila script executes successfully as part of this feature.
Comment 2 David Vancouvering 2008-06-18 23:53:42 UTC
*** Issue 129828 has been marked as a duplicate of this issue. ***
Comment 3 David Vancouvering 2008-07-10 17:58:49 UTC
With this changeset, the foundational support in db.mysql module is there, and now we can build the Sakila NBM for the
update center after I return from vacation (post feature freeze).

http://hg.netbeans.org/main?cmd=changeset;node=a45560212d61
Comment 4 David Vancouvering 2008-08-12 19:27:16 UTC
*** Issue 136541 has been marked as a duplicate of this issue. ***
Comment 5 David Vancouvering 2008-08-12 19:45:38 UTC
I am hitting the same issue as 136541.  It turns out that the issue is a single line in the data script, and it's an
insert into the 'staff' table where an actual *picture* binary is being inserted.  

So somehow the mysql command-line tool is able to handle a binary stream like this -- perhaps it detects that the column
is binary and parses it correctly.  But our poor parser is completely at a loss, and even if we got it right, I suspect
passing in a binary as a String to JDBC would fail.

So my workaround is I will take the binary data that's jammed into the sakila data script, store it in a separate file,
and load it manually.  Sheesh!
Comment 6 John Baker 2008-08-13 01:25:51 UTC
I think there is another problem, but not related to sakila.

The sakila script I downloaded has some statements that end with 2 semicolons.
Execution fails at those lines with 2 semicolons.  I'll file a separate issue

For example:

-- Fails:
DELIMITER;;

-- Succeeds:
DELIMITER;    
Comment 7 John Baker 2008-08-13 01:40:35 UTC
actually it's not the 2 semicolons, it's a command that follows a comment

Passes:
-- hello

Passes:
DELIMITER;;

Fails:
-- hello
DELIMITER;
Comment 8 David Vancouvering 2008-08-13 15:14:26 UTC
I know about the delimiter problem and have already fixed it.
Comment 9 David Vancouvering 2008-08-13 18:25:33 UTC
Committed changes - this works when I test it through "Run Project." 

Next will work on building and testing NBM and getting onto the dev UC for testing.
Comment 10 Quality Engineering 2008-08-14 15:56:34 UTC
Integrated into 'main-golden', available in build *200808141419* on http://bits.netbeans.org/dev/nightly/
Changeset: http://hg.netbeans.org/main/rev/d84405be8559
User: David Van Couvering <davidvc@netbeans.org>
Log: #134307 - Sakila sample database plugin
Ready for the dev UC
Comment 11 David Vancouvering 2008-09-15 20:25:18 UTC
This is done, with my getting it ready for the Stable UC
Comment 12 Roman Mostyka 2008-09-16 10:34:53 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo