Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 134221 - IllegalStateException at org.netbeans.modules.beans.beaninfo.GenerateBeanInfoAction$BeanInfoWorker.checkState
IllegalStateException at org.netbeans.modules.beans.beaninfo.GenerateBeanInfo...
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Beans
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jan Pokorsky
issues@java
http://statistics.netbeans.org/except...
61fixes3-fixed EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 07:38 UTC by Jiri Prox
Modified: 2008-09-04 13:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.07 KB, text/plain)
2008-04-30 07:38 UTC, Jiri Prox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2008-04-30 07:38:41 UTC
Build: NetBeans IDE Dev (Build 20080429222325)
VM: Java HotSpot(TM) Client VM, 11.0-b11, Java(TM) SE Runtime Environment, 1.6.0_10-beta-b14
OS: Linux, 2.6.22-14-generic, i386

User Comments: 
ISE when saving in beaninfo editor for the second time.

Steps to reproduce:
1) switch to designer tab of beaninfo
2) make any changes and save
3) make further changes and save
Comment 1 Jiri Prox 2008-04-30 07:38:46 UTC
Created attachment 60848 [details]
stacktrace
Comment 2 Jana Maleckova 2008-05-23 08:41:52 UTC
This issue is more serious than it looks for the first time. 
If I try to save the editor for the second time not only problem with exception occurs but finally the whole project is
not possible to clean &build just due to the saving fault.
I found only one solution to make project build-able again and this is: Close BeanInfo editor without saving which leads
to data loss....therefore I increase the priority to P2. 

StackTrace:
===========
java.lang.IllegalStateException
	at org.netbeans.modules.beans.beaninfo.GenerateBeanInfoAction$BeanInfoWorker.checkState(GenerateBeanInfoAction.java:287)
	at
org.netbeans.modules.beans.beaninfo.GenerateBeanInfoAction$BeanInfoWorker.generateSources(GenerateBeanInfoAction.java:184)
	at org.netbeans.modules.beans.beaninfo.BIEditorSupport.saveDocument(BIEditorSupport.java:183)
	at org.netbeans.modules.beans.beaninfo.BIEditorSupport$Environment$SaveSupport.save(BIEditorSupport.java:640)
	at org.netbeans.core.ExitDialog.save(ExitDialog.java:186)
Comment 3 Jan Pokorsky 2008-06-17 13:52:26 UTC
fixed as http://hg.netbeans.org/main/rev/986fba31f781
Comment 4 Jiri Prox 2008-06-17 14:03:09 UTC
candidate for patch 3
Comment 5 Quality Engineering 2008-06-18 15:59:35 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #267 build
Changeset: http://hg.netbeans.org/main/rev/986fba31f781
User: Jan Pokorsky <jpokorsky@netbeans.org>
Log: #134221: fixed wrong worker state after generating source code
Comment 6 rbalada 2008-08-04 15:53:55 UTC
Please note that NetBeans 6.1 Patch3 cut-off is going to happen on close of
business August 5th. If you would like to have bugfix for this issue as part of
NetBeans 6.1 Patch3, then this issue must have information about bugfix' trunk
changeset and it's status must be "VERIFIED".
Comment 7 Jiri Prox 2008-08-04 15:55:37 UTC
verified
Comment 8 rbalada 2008-08-04 17:04:40 UTC
I've transplanted the changeset http://hg.netbeans.org/main/rev/986fba31f781 into release61_fixes repository as
http://hg.netbeans.org/release61_fixes/rev/04bc7705bc1f
Comment 9 Jiri Prox 2008-08-21 08:36:14 UTC
verified in patch


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo