Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 134192 - Changes in list of C/C++ filename extensions disappear after restart
Changes in list of C/C++ filename extensions disappear after restart
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Sergey Grinev
issues@cnd
61fixes2-fixed
:
: 134391 (view as bug list)
Depends on:
Blocks: 135891
  Show dependency treegraph
 
Reported: 2008-04-29 20:33 UTC by bb125
Modified: 2008-07-10 15:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE cannot open file with new extension (6.74 KB, text/plain)
2008-04-30 07:01 UTC, Alexander Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bb125 2008-04-29 20:33:05 UTC
Netbeans 6.1, jdk 1.6.0_06, opensuse 10.3

* Open Tools -> Options -> C/C++ -> Other
* Add a new filename extension and optionally change the default.
* Netbeans recognizes the new extensions as expected.
* End the netbeans session and start netbeans again.
* The changes in the filename extension list are lost.

Note: The new filename extensions can be seen in the configuration file
.netbeans/6.1/config/Preferences/org/netbeans/modules/cnd.properties
after ending the netbeans session. Unfortunately the configuration data
is changed to default when starting a new netbeans session.
Comment 1 Alexander Simon 2008-04-30 07:01:49 UTC
Created attachment 60844 [details]
IDE cannot open file with new extension
Comment 2 Alexander Simon 2008-04-30 07:02:41 UTC
P2 because it is regression
Comment 3 Alexander Simon 2008-04-30 07:11:44 UTC
Scenario for attachment:
1. start IDE with empty user dir
2. add new extension for  header
3. create new application
4. add new header with recently added extension
5. all editor features ok
6. restart IDE
7. see exception (in current developer IDE version)
8. file does not open in editor
9. added extension is missed
Comment 4 Alexander Simon 2008-04-30 07:20:56 UTC
Last scenario repeated in NB 6.1 (without exception that I suppose is suppressed)
So I think the bug is candidate to fix in path.
If user uses nonstandard file extension (s)he cannot use NB 6.1 for c/c++ development at all.
Comment 5 soldatov 2008-05-02 13:36:57 UTC
*** Issue 134391 has been marked as a duplicate of this issue. ***
Comment 6 Sergey Grinev 2008-05-05 15:59:14 UTC
fixed by http://hg.netbeans.org/main/rev/08cf02914398
Comment 7 soldatov 2008-05-16 08:41:25 UTC
verified in 200805150003 build
Comment 8 jinb 2008-06-02 14:20:08 UTC
fix backported into release61_fixes branch
http://hg.netbeans.org/release61_fixes/rev/5c3b8b48731a


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo