Bug 134181 - I18N - Can't open DTD Documentation file from the ide
I18N - Can't open DTD Documentation file from the ide
Status: RESOLVED WORKSFORME
Product: ide
Classification: Unclassified
Component: Extbrowser
6.x
All All
: P2 (vote)
: TBD
Assigned To: Peter Zavadsky
issues@ide
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-29 18:25 UTC by kaa
Modified: 2008-06-19 00:54 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2008-04-29 18:25:20 UTC
Product Version: NetBeans IDE Dev (Build 200804291203)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
Project encodings: UTF-8/Win-31j. See also issue about javadoc 128033 (fixed and verified)

Steps:
1. Create JavaApp using eng name and mbyte chars in the project folder
2. Add XML doc
3. Invoke Generate DTD from the pop-up
4. Select dtd doc then invoke 'Generate Documentation...' from the pop-up
5. Select generated html file and open it using 'View' from the pop-up menu

For the project located in C:\新規フォルダ\JavaApplication8
Firefox opens with the following URL:
file:///C:/%E8%AD%81%EF%BD%B0%E9%9A%95%E4%B8%8A%E3%83%B5%E7%B9%A7%EF%BD%A9%E7%B9%9D%EF%BD%AB%E7%B9%9D%C2%80/JavaApplication8/src/javaapplication8/newXMLDocumentDocumentation.html

Err message is shown:
Firefox can't find the file at /C:/譁ー隕上ヵ繧ゥ繝ォ繝
€/JavaApplication8/src/javaapplication8/newXMLDocumentDocumentation.html.

IE also was not able to open html file using this URL.

If the app has mbyte in its name  (in the step1) the URL was generated incorrectly:
App location: C:\新規フォルダ\おい
Firefox started with the following URL:
file:///C:/%E8%AD%81%EF%BD%B0%E9%9A%95%E4%B8%8A%E3%83%B5%E7%B9%A7%EF%BD%A9%E7%B9%9D%EF%BD%AB%E7%B9%9D%C2%80/%E7%B8%BA%E7%BF%AB%EF%BC%9E/src/%E7%B8%BA%E7%BF%AB%EF%BC%9E/newXMLDocumentDocumentation.html
Err message shows incorrect URL (see '>'):
Firefox can't find the file at /C:/譁ー隕上ヵ繧ゥ繝ォ繝€/縺翫>/src/縺翫>/newXMLDocumentDocumentation.html.

IE also was not able to open html file using this URL.
Comment 1 Peter Zavadsky 2008-06-19 00:05:52 UTC
I can't reproduce this on linux. I am trying to get to try it on Windows to see more.
Comment 2 _ krystyna 2008-06-19 00:42:08 UTC
Not reproducible on winXP
 NetBeans IDE Dev (Build 200806181204)
Was able to open the file, no errors.
Comment 3 Peter Zavadsky 2008-06-19 00:54:16 UTC
Closing as works for me. Please, reopen if you experience again.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo