Bug 134164 - I18N - Toplink failed in finding Persistence provider on the multibyte folder path
I18N - Toplink failed in finding Persistence provider on the multibyte folder...
Status: RESOLVED DUPLICATE of bug 119567
Product: javaee
Classification: Unclassified
Component: Persistence
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Dongmei Cao
issues@javaee
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-29 14:43 UTC by taisoft
Modified: 2008-09-19 20:19 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description taisoft 2008-04-29 14:43:20 UTC
Toplink failed in finding Persistence provider only in multibyte-coded folder path.
(using NB IDE 6.1RC2, JDK 1.6, MS Windows XP SP2 Korean version)

generating error steps :

1) do steps from start to Running the Generated Application according to the tutorial of Building a Java Desktop 
Database Application (http://www.netbeans.org/kb/60/java/gui-db.html). 

  path condition : set the project path as "D:\NetBeans\Test\CarsApp"
  ==> if run : succeed with a CAR data form view. 

2) do steps same as 1).

  path condition : set the project path as "D:\NetBeans\Test Separate\CarsApp" (with a separated folder name)
              (or, simmly copy the folder and files created by (1) to this folder location.)  

  ==> if run : failed with the following output, no form view: 

3) do steps same as 1).

  path condition : set the project path as "D:\NetBeans\테스트\CarsApp" ('테스트' is Korean multibyte codes for 'Test')

  ==> if run : failed with the following output, no form view: (!!!!)

init:
deps-jar:
compile:
run:
2008. 4. 29 오후[==>"P.M"] 1:09:48 org.jdesktop.application.Application$1 run
심각[==>"Serious"]: Application class carsapp.CarsApp failed to launch
javax.persistence.PersistenceException: No Persistence provider for EntityManager named car_databasePU:  The following 
providers:
oracle.toplink.essentials.PersistenceProvider
oracle.toplink.essentials.ejb.cmp3.EntityManagerFactoryProvider
Returned null to createEntityManagerFactory.

        at javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:154)
        at javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:83)
        at carsapp.CarsView.initComponents(CarsView.java:288)
        at carsapp.CarsView.<init>(CarsView.java:36)
        at carsapp.CarsApp.startup(CarsApp.java:19)
        at org.jdesktop.application.Application$1.run(Application.java:171)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
Exception in thread "AWT-EventQueue-0" java.lang.Error: Application class carsapp.CarsApp failed to launch
        at org.jdesktop.application.Application$1.run(Application.java:177)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
Caused by: javax.persistence.PersistenceException: No Persistence provider for EntityManager named car_databasePU:  The 
following providers:
oracle.toplink.essentials.PersistenceProvider
oracle.toplink.essentials.ejb.cmp3.EntityManagerFactoryProvider
Returned null to createEntityManagerFactory.

        at javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:154)
        at javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:83)
        at carsapp.CarsView.initComponents(CarsView.java:288)
        at carsapp.CarsView.<init>(CarsView.java:36)
        at carsapp.CarsApp.startup(CarsApp.java:19)
        at org.jdesktop.application.Application$1.run(Application.java:171)
        ... 8 more
BUILD SUCCESSFUL (total time: 2 seconds)
Comment 1 David Vancouvering 2008-05-14 00:52:44 UTC
Perhaps this is a db module problem, but it looks more like a Persistence or even a Toplink problem.  Please free to
bounce back to this team if necessary, but please help me understand what the root cause is, it's not clear so far.
Comment 2 Ken Frank 2008-07-05 04:01:33 UTC
this might be same as a previous known issue that is fixed
in gf 2.1, but not in 2.0 and perhaps not in gf3. I'll add the id to
this issue soon.

ken.frank@sun.com
Comment 3 Ken Frank 2008-07-05 04:13:07 UTC
correction - this was an issue before in form category with dbase app
related to toplink, see 119567 and glassfish issue 3827.
Does it seem that this is the same ?
I see that the tutorial using desktop dbase app was where this was seen.

I don't think it was seen in using non ascii path or project name using
new entity class from dbase and jsp files from entity class.

as mentioned, the fix is supposed to be in gf 2.1 but not in any gf 2.0.x;
as to gf3, I don't think toplink is in gfv3 but eclipselink libraries are
and we will look to see how these work for this type of app.

ken.frank@sun.com
Comment 4 Dongmei Cao 2008-09-19 20:19:09 UTC
> Does it seem that this is the same ?

Yes, it is the same issue. Close it as dup of 119567

*** This issue has been marked as a duplicate of 119567 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo