Bug 134053 - Freeze on finish New Mobility Project
Freeze on finish New Mobility Project
Status: RESOLVED FIXED
Product: javame
Classification: Unclassified
Component: -- Other --
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: _ tboudreau
issues@mobility
: TEST, THREAD
: 133218 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 10:03 UTC by Alexander Kouznetsov
Modified: 2008-10-09 13:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (43.14 KB, text/plain)
2008-04-28 10:04 UTC, Alexander Kouznetsov
Details
Messages.log (109.48 KB, text/plain)
2008-04-28 10:04 UTC, Alexander Kouznetsov
Details
Screenshot (24.90 KB, image/png)
2008-04-28 10:06 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2008-04-28 10:03:05 UTC
[ideTestRunner]   Product Version         = NetBeans IDE Dev (Build 200804271202)
[ideTestRunner]   Operating System        = Windows XP version 5.1 running on x86
[ideTestRunner]   Java; VM; Vendor        = 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19; Sun Microsystems Inc.

Performance test went into a freeze on finishing New Project wizard for mobility project.
Comment 1 Alexander Kouznetsov 2008-04-28 10:04:06 UTC
Created attachment 60732 [details]
Thread dump
Comment 2 Alexander Kouznetsov 2008-04-28 10:04:58 UTC
Created attachment 60733 [details]
Messages.log
Comment 3 Alexander Kouznetsov 2008-04-28 10:06:49 UTC
Created attachment 60734 [details]
Screenshot
Comment 4 Petr Suchomel 2008-06-20 15:46:07 UTC
Could you provide the way to run this test?
Comment 5 Alexander Kouznetsov 2008-09-01 13:05:36 UTC
This is not a performance bug
Comment 6 _ tboudreau 2008-09-29 21:03:42 UTC
I have run into this issue as well, during testing of fixes for issue 147403.

The fix for issue 147403 changes the call sequence and threading when a new project is created (by taking sample midlet creation off the event thread).  With 
no locks possibly being held when the sample midlet is created (it is now done in a background thread).  

In the attached thread dump, the AWT thread is blocked inside org.netbeans.modules.mobility.project.J2MEProjectGenerator$4.doPostGeneration(), which 
creates the sample midlet.  So it is very likely that the fix for issue 147403 (I have attached a patch) will also fix this bug.
Comment 7 _ tboudreau 2008-10-01 00:33:34 UTC
*** Issue 133218 has been marked as a duplicate of this issue. ***
Comment 8 Alexander Kouznetsov 2008-10-07 15:51:20 UTC
To run test:
1. Get the repository and build
2. Run ant in performance dir
3. Unzip qa\performance\mobility\wtk252-windows.zip (or linux) from cvs repository into nbbuild\netbeans\mobility8
4. Open performance\mobility project
5. Run MeasureMobilitySetupTest to prepare environemtn
6. Run CreateMobilityProject to reproduce test
Comment 9 _ tboudreau 2008-10-08 21:11:58 UTC
Is this reproducible after the fix for issue 147403?  That fix completely changed the call order and what thread the
code that was causing the freeze-up runs on.
Comment 10 Alexander Kouznetsov 2008-10-09 13:09:34 UTC
It looks like the fix helped


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo