Bug 134045 - IntelliJ IDEA-compliant keymap created
IntelliJ IDEA-compliant keymap created
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Key bindings
6.x
All All
: P2 with 2 votes (vote)
: 6.x
Assigned To: Max Sauer
issues@editor
: PLAN
: 75742 154119 (view as bug list)
Depends on:
Blocks: 152193
  Show dependency treegraph
 
Reported: 2008-04-27 22:00 UTC by scwells72
Modified: 2009-02-19 20:45 UTC (History)
5 users (show)

See Also:
Issue Type: TASK
:


Attachments
IntelliJ IDEA keymap for NetBeans 6.1+ (41.67 KB, application/octet-stream)
2008-04-27 22:09 UTC, scwells72
Details
Updated with changes to move line/selection up/down (41.67 KB, application/octet-stream)
2008-04-28 03:05 UTC, scwells72
Details
Updated to include SHIFT-ESC as Close Window (42.84 KB, application/octet-stream)
2008-05-09 18:09 UTC, scwells72
Details
Newer keymap for 6.5bRC2 and some of the gap closure between IDEA and NetBeans from that release (41.78 KB, application/x-compressed)
2008-09-19 21:58 UTC, scwells72
Details

Note You need to log in before you can comment on or make changes to this bug.
Description scwells72 2008-04-27 22:00:59 UTC
I posted on nbdev that I'd created a pretty comprehensive keymap for users of IntelliJ IDEA:

http://www.nabble.com/How-can-I-submit-my-IntelliJ-IDEA-keymap-for-inclusion-in-the-product--ts16834719.html

I was asked to open an issue so that perhaps it could get incorporated into the base product as an out-of-the-box keymap
option.  This is that issue, and I'll be looking at how to attach the keymap to this issue after initial submission.
Comment 1 scwells72 2008-04-27 22:09:51 UTC
Created attachment 60725 [details]
IntelliJ IDEA keymap for NetBeans 6.1+
Comment 2 scwells72 2008-04-27 22:12:14 UTC
I've attached what I think should be all of the files that comprise the custom keymap.  If for whatever reason these
files are not sufficient, please let me know and I can send you my entire config dir.  Please let me know if there's
anything else I can do to help get this into an upcoming version!

Comment 3 scwells72 2008-04-28 03:05:52 UTC
Created attachment 60728 [details]
Updated with changes to move line/selection up/down
Comment 4 scwells72 2008-04-28 03:07:01 UTC
Please use the most recent attachment.  I realized that CTRL-SHIFT-UP and CTRL-SHIFT-DOWN weren't mapped to move
selection/line up/down on the keymap that I'd uploaded earlier.
Comment 5 scwells72 2008-05-09 18:05:49 UTC
One additional comment.  Please reassign SHIFT-ESC to "Close Window" to more accurately mimic the IntelliJ IDEA
behavior.  I can upload a replacement keymap if that's preferable.
Comment 6 scwells72 2008-05-09 18:09:07 UTC
Created attachment 61191 [details]
Updated to include SHIFT-ESC as Close Window
Comment 7 scwells72 2008-05-09 18:09:51 UTC
Never mind.  I attached an updated keymap with SHIFT-ESC properly mapped.  Just use the latest attachment.
Comment 8 maksym 2008-06-18 19:19:07 UTC
Hi. I just started migration from IDEA to NetBeans.
This keymap is very useful. Thank you.

But let me suggest some useful keymaps (from IDEA Keymap dialog box):
# Editor Actions
  - Select Word at Caret (Ctrl+Shift+W)
# Main Menu
  # Edit
    - Undo (Alt+Backspace)
    - Redo (Alt+Shift+Backspace)
  # Window
    - Hide All Windows (Ctrl+Shift+F12)

Also, shortcuts in tooltips in the small toolbar of the 
java source code editor window are not correct 
(bookmarks, ets.).

... to be continued

P.S. IDEA colors and fonts, coding style will be usefull too.
Comment 9 Vitezslav Stejskal 2008-06-19 10:36:11 UTC
Thanks for the patch. I'll add the profile to the IDE.
Comment 10 maksym 2008-06-19 17:14:48 UTC
I implemented Undo (Alt+Backspace) and Paste (Shift+Insert)
using macros. Other actions, those are absent in keymap, 
can be implemented as well.
Comment 11 maksym 2008-06-19 17:48:15 UTC
But how to open recent files list?
Comment 12 scwells72 2008-06-19 19:22:53 UTC
As for a recent files list, NetBeans doesn't have such a feature yet other than in the File menu.  I've actually created
a plug-in with that feature for 6.1+, but I haven't posted it anywhere yet.  It works pretty much like the one in IDEA
as that's what I used as a precedent.  The same plug-in also includes an incomplete implementation of IDEA's CTRL+ALT+B
go to implementation functionality.
Comment 13 scwells72 2008-09-19 21:58:27 UTC
Created attachment 70174 [details]
Newer keymap for 6.5bRC2 and some of the gap closure between IDEA and NetBeans from that release
Comment 14 Vitezslav Stejskal 2008-10-06 15:43:23 UTC
*** Issue 75742 has been marked as a duplicate of this issue. ***
Comment 15 rukus 2008-10-09 08:32:59 UTC
What about inluding this patch in netbeans 6.5 out-of-box?
Comment 16 Jan Becicka 2008-10-09 10:13:25 UTC
Too late for 6.5. But should be integrated.
Comment 17 Vitezslav Stejskal 2008-12-02 10:54:24 UTC
*** Issue 154119 has been marked as a duplicate of this issue. ***
Comment 18 Max Sauer 2009-01-06 10:24:57 UTC
Fixed, please verify.
---
http://hg.netbeans.org/main/rev/87e7d88c8eb9

Comment 19 Quality Engineering 2009-01-07 05:36:15 UTC
Integrated into 'main-golden', will be available in build *200901070201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/87e7d88c8eb9
User: Max Sauer <msauer@netbeans.org>
Log: #134045: IntelliJ IDEA-compliant keymap created


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo