Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 133931 - New BeanInfo support broke IDE features like Select in Projects...
New BeanInfo support broke IDE features like Select in Projects...
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Beans
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jan Pokorsky
issues@java
61fixes2-fixed
:
: 133169 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-25 13:11 UTC by Michel Graciano
Modified: 2008-07-10 15:07 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Simple java project (11.00 KB, application/x-compressed)
2008-04-25 14:33 UTC, Michel Graciano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2008-04-25 13:11:32 UTC
The new BeanInfo support broke IDE features like Select in Projects and Files. Another feature broken is that project
don't recognize that file is inside a project and the CVS don't works too.
Comment 1 Jan Pokorsky 2008-04-25 13:18:57 UTC
Sorry but I do not understand. Could describe what's broken in more details?
Comment 2 Michel Graciano 2008-04-25 13:31:24 UTC
When I create a BeanInfo for a component (using the new support or not), the IDE don't recognize that this file as a
project inside a project. So, Ctrl+Shift+1 don't work anymore. Any operation at file that need to know which project
this file is inside, as CVS operation and so on. BTW, just operations on file opened on editor don't works. The menu and
popup on Projects are working for now. I hope to be clear now.

For me, it is a regression because now I can't use this action for my old beaninfos, created by BeanInfo support or not.

Regards.
Comment 3 Jan Pokorsky 2008-04-25 14:15:37 UTC
> the IDE don't recognize that this file as a project inside a project
??
I have open MyBeanInfo.java in editor in Source mode. Using Ctrl+Shift+1 selects the proper file in the Project view of
my J2SE project as expected. The Move Class refactoring works as well regardless it was invoked from the editor popup or
the Project view node popup.

Product Version: NetBeans IDE Dev (Build 080418)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Linux version 2.6.22-14-generic running on i386; UTF-8; en_US (nb)

Could you create a simple project demonstrating the problem and attach it here?
Comment 4 Michel Graciano 2008-04-25 14:32:55 UTC
Product Version: NetBeans IDE 6.1 RC2 (Build 200804170002)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Linux version 2.6.22-14-generic running on i386; ISO-8859-1; pt_BR (nb)
Comment 5 Michel Graciano 2008-04-25 14:33:48 UTC
Created attachment 60695 [details]
Simple java project
Comment 6 Michel Graciano 2008-04-25 14:34:26 UTC
My main project is a free form project, which don't work too.
Comment 7 Jiri Prox 2008-04-25 14:39:25 UTC
I can reproduce the Select in ... problem too. 
Comment 8 Jan Pokorsky 2008-04-25 15:38:38 UTC
Thanks for the sample. It is reproducible reliably now. I will investigate.
Comment 9 Jan Pokorsky 2008-04-25 16:47:59 UTC
fixed in http://hg.netbeans.org/main/rev/3245f26c7e1f

jiriprox: this would deserves to be included in 6.1 patches. It is really annoying bug.
Comment 10 Jiri Prox 2008-04-25 16:56:48 UTC
Yes, I agree
Comment 11 Quality Engineering 2008-04-26 03:54:17 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #158 build
Changeset: http://hg.netbeans.org/main/rev/3245f26c7e1f
User: Jan Pokorsky <jpokorsky@netbeans.org>
Log: #133931: missing activate nodes in multi view
Comment 12 Michel Graciano 2008-04-26 21:27:44 UTC
Maybe the TM should br updated to 6.1?
Comment 13 Jan Pokorsky 2008-04-28 08:38:36 UTC
TM reflects real state of the fix (where it was or will be fixed). NB 6.1 has been released and is closed for fixes. The
back-porting is ensured by 'release61_fixes_candidate2' in status whiteboard.
Comment 14 Jan Pokorsky 2008-04-29 14:41:17 UTC
*** Issue 133169 has been marked as a duplicate of this issue. ***
Comment 15 Jiri Prox 2008-06-03 09:28:27 UTC
verified
Comment 16 pgebauer 2008-06-03 20:07:01 UTC
The fix has been ported into the release61_fixes branch:

http://hg.netbeans.org/release61_fixes/efda6cfd3223


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo